Bug 967209 - RHEL5.8, Assertion (head_size <=63) at dos.c263 in function probe_partition_for_geom() failed [NEEDINFO]
RHEL5.8, Assertion (head_size <=63) at dos.c263 in function probe_partition_f...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: parted (Show other bugs)
5.8
All Linux
medium Severity medium
: rc
: 5.10
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-25 10:04 EDT by Zhenyong(Jerry) Jiang
Modified: 2014-06-02 09:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:04:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (jzhenyon)


Attachments (Terms of Use)

  None (edit)
Description Zhenyong(Jerry) Jiang 2013-05-25 10:04:02 EDT
Description of problem:

When install RHEL5.8 on a IBM x3560M4 which is connected to a SAN storage, it reports "Assertion (head_size <=63) at dos.c263 in function probe_partition_for_geom() failed" during installation.

After removing SAN connection, then installation can work and did not report any error.



Version-Release number of selected component (if applicable):

RHEL5.8


How reproducible:

100% in customer site.


Steps to Reproduce:
1. connect the system to a san storage.
2. install rhel5.8
3. during installation, anaconda would report the error and installation would fail.

Actual results:

Get error during installation and can not install the OS.

Expected results:

Should not get the error.

Additional info:
RHEL6 does not have this issue even if system has SAN connected.
Comment 1 RHEL Product and Program Management 2013-05-25 10:26:17 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 2 Brian Lane 2013-05-29 18:18:44 EDT
I can probably backport upstream patch 244b1b25a12

" The CHS geometry values are calculated based on the existing partition
    information. The values can't always be calculated, and the partition
    may be corrupt so instead of throwing an assertion just return 0 and
    carry on."

You can usually work around this by using dd to remove the partition table and re-partitioning it with parted. Note that this will result in losing the data on the disk.
Comment 4 RHEL Product and Program Management 2014-03-07 08:36:03 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 RHEL Product and Program Management 2014-06-02 09:04:14 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.