Bug 967227 - "Download Only" useless for packages removing
"Download Only" useless for packages removing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-25 15:15 EDT by nucleo
Modified: 2013-05-27 04:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 04:24:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2013-05-25 15:15:10 EDT
Description of problem:
If I try to remove package and press "d" after "Is this ok [y/d/N]:" no action performed.


Version-Release number of selected component (if applicable):
yum-3.4.3-91.fc19


Actual results:
# yum remove cmake
Resolving Dependencies
--> Running transaction check
---> Package cmake.i686 0:2.8.10.2-5.fc19 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================
 Package              Arch                Version                         Repository              Size
=======================================================================================================
Removing:
 cmake                i686                2.8.10.2-5.fc19                 @fedora                 24 M

Transaction Summary
=======================================================================================================
Remove  1 Package

Installed size: 24 M
Is this ok [y/d/N]: d
Background downloading packages, then exiting:
exiting because "Download Only" specified

Expected results:
Is this ok [y/N]:
Comment 1 Zdeněk Pavlas 2013-05-27 04:24:59 EDT
Not a bug (yum did not run the transaction, just downloaded all needed packages- none in this case), just annoyance.  Fixed upstream already.  
http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=16489d742

Note You need to log in before you can comment on or make changes to this bug.