Bug 967229 - espeak -w not always producing sane audio file
espeak -w not always producing sane audio file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: espeak (Show other bugs)
rawhide
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-25 15:24 EDT by Alexander Todorov
Modified: 2013-08-23 10:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 10:25:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test.txt (105 bytes, text/plain)
2013-05-25 15:24 EDT, Alexander Todorov
no flags Details
test.wav (880 bytes, audio/x-wav)
2013-05-25 15:24 EDT, Alexander Todorov
no flags Details
test2.wav (157.21 KB, audio/x-wav)
2013-05-25 15:24 EDT, Alexander Todorov
no flags Details
Proposed fix (538 bytes, patch)
2013-08-12 10:51 EDT, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Alexander Todorov 2013-05-25 15:24:00 EDT
Created attachment 753154 [details]
test.txt

Description of problem:

When I use espeak with the -w file.wav option sometimes it doesn't produce a sane audio file, although it can speak the text correctly.


Version-Release number of selected component (if applicable):
espeak-1.47.11-1.el6.x86_64 (rebuilt from src.rpm on RHEL6.4)

How reproducible:
Always

Steps to Reproduce:
1. cat test.txt | espeak -v europe/bg -w test.wav
2. ls -l test.wav 
-rw-rw-r--. 1 atodorov atodorov 880 25 май 22,19 test.wav
3. totem test.wav - nothing

OTOH

$ cat test.txt | espeak -v europe/bg --stdout > test2.wav
$ ls -l test2.wav 
-rw-rw-r--. 1 atodorov atodorov 160982 25 май 22,20 test2.wav
$ totem test2.wav - es expected


Actual results:

Text is spoken correctly (in Bulgarian). The first audio file is garbage, it's too small and when opened with Totem it doesn't play anything. Length is 0 sec.

The second audio file is correct and plays correctly in Totem.

Expected results:


Additional info:
I'm using the latest espeak RPM compiled from the src.rpm in Koji on RHEL6 because earlier versions in EPEL doesn't support Bulgarian language. However this shouldn't affect ability to write audio file.
Comment 1 Alexander Todorov 2013-05-25 15:24:34 EDT
Created attachment 753155 [details]
test.wav
Comment 2 Alexander Todorov 2013-05-25 15:24:52 EDT
Created attachment 753156 [details]
test2.wav
Comment 3 Jaroslav Škarvada 2013-08-12 10:51:40 EDT
Created attachment 785736 [details]
Proposed fix

Upstream ticket:
http://sourceforge.net/p/espeak/bugs/105/
Comment 4 Jaroslav Škarvada 2013-08-12 10:54:33 EDT
You can workaround it by:

$ espeak -ftest.txt -v europe/bg -w test.wav
Comment 5 Jaroslav Škarvada 2013-08-23 10:21:15 EDT
I am pushing it into rawhide. I can roll-back it later in case upstream will come with different solution.

Note You need to log in before you can comment on or make changes to this bug.