Bug 967240 - FutureFeature: ausearch to checkpoint its output to only report new events on successive executions
Summary: FutureFeature: ausearch to checkpoint its output to only report new events on...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: audit
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Steve Grubb
QA Contact: Ondrej Moriš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-25 22:32 UTC by Burn Alting
Modified: 2018-12-03 18:56 UTC (History)
3 users (show)

Fixed In Version: audit-2.3.7-1.el6
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:14:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1515 normal SHIPPED_LIVE audit bug fix and enhancement update 2014-10-14 01:22:21 UTC

Description Burn Alting 2013-05-25 22:32:00 UTC
Description of problem:
FutureFeature:

In order to better support the centralisation of audit, we require the ausearch utility to be able to checkpoint it's output such that successive invocations of the tool only output new complete events.

This is a SOLVED problem with a patch provided to the auditd mailing list as per

    From: Burn Alting <burn swtf dyndns org>
    To: linux-audit redhat com
    Subject: [PATCH] ausearch: Add checkpoint capability and have incomplete logs carry forward when processing multiple audit.log files
    Date: Sat, 11 May 2013 15:59:34 +1000


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 RHEL Program Management 2013-10-13 23:33:05 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 4 Steve Grubb 2014-03-27 14:20:04 UTC
Applied in upstream commit 934.

Comment 6 Steve Grubb 2014-03-27 17:31:26 UTC
Testing this can be done as follows:

1) ausearch --start today --checkpoint chk
2) ausearch --start today --checkpoint chk
3) ausearch --start today --checkpoint chk
4) auditctl -m test
5) ausearch --start today --checkpoint chk
6) ausearch --start today --checkpoint chk

You should see events on steps 1 & 5. None on 2, 3, & 6.

Comment 7 Steve Grubb 2014-06-04 02:06:36 UTC
audit-2.3.7-1.el6 was built to resolve this problem.

Comment 11 errata-xmlrpc 2014-10-14 07:14:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1515.html


Note You need to log in before you can comment on or make changes to this bug.