Bug 967242 - migrate w/o shared storage fails: error while loading state section id 2
migrate w/o shared storage fails: error while loading state section id 2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-25 18:46 EDT by Cole Robinson
Modified: 2013-06-20 10:15 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 10:15:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
qemu log on the source host (1.89 KB, text/plain)
2013-05-25 18:48 EDT, Cole Robinson
no flags Details
qemu log on the destination host (1.89 KB, text/plain)
2013-05-25 18:48 EDT, Cole Robinson
no flags Details

  None (edit)
Description Cole Robinson 2013-05-25 18:46:56 EDT
F19 source and destination host (I'm using a VM for the destination but I don't think that matters).

Both hosts have qemu-1.4.2-1, which has the migration cleanup series from qemu-1.5 backported, including this commit which sounds like it could have been related:

commit 45d723c48255328fbd5128c4c70c91103e420590
Author: Michael Roth <mdroth@linux.vnet.ibm.com>
Date:   Thu May 16 16:25:44 2013 -0500

    Revert "migration: don't account sleep time for calculating bandwidth"

I'm migrating with: sudo virsh migrate --p2p --tunnelled --verbose --live  --copy-storage-all f19-migrate qemu+ssh://root@192.168.123.99/system

After progress meter reaches 99% the migration fails. This is in the destination qemu log:

Receiving block device images
qemu: warning: error while loading state section id 2
load of migration failed

Full qemu command line and logs coming up.
Comment 1 Cole Robinson 2013-05-25 18:48:32 EDT
Created attachment 753190 [details]
qemu log on the source host
Comment 2 Cole Robinson 2013-05-25 18:48:59 EDT
Created attachment 753191 [details]
qemu log on the destination host
Comment 3 Cole Robinson 2013-05-25 18:55:51 EDT
FWIW I was more or less following the steps here:

https://fedoraproject.org/wiki/QA:Testcase_Live_Migration_using_libvirt/virsh
Comment 4 Paolo Bonzini 2013-06-20 07:58:30 EDT
Can you try without --p2p and --tunnelled?
Comment 5 Cole Robinson 2013-06-20 10:15:44 EDT
Yeah I think this was some side effect of libvirt silently falling back to the old storage migration method, which current F19 libvirt doesn't do anymore. Since we don't really care about that method, closing this as WONTFIX. I'll reopen if I can reproduce with the nbd migration method.

Note You need to log in before you can comment on or make changes to this bug.