This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 967271 - [abrt] WARNING: at drivers/net/wireless/ath/carl9170/tx.c:992 carl9170_op_tx+0x711/0x8a0 [carl9170]()
[abrt] WARNING: at drivers/net/wireless/ath/carl9170/tx.c:992 carl9170_op_tx+...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:624b64a7ea4c2db9cc3f6788042...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 04:07 EDT by Karsten Stöckmann
Modified: 2013-07-11 23:11 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-3.9.9-201.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-30 21:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (72.08 KB, text/plain)
2013-05-26 04:08 EDT, Karsten Stöckmann
no flags Details
0001-carl9170-fix-frame-drop-and-WARN-due-to-minstrel_ht-.patch (5.13 KB, text/plain)
2013-06-21 07:15 EDT, Stanislaw Gruszka
no flags Details

  None (edit)
Description Karsten Stöckmann 2013-05-26 04:07:54 EDT
Description of problem:
This has been occuring frequently since the 3.9.2 kernel, triggering lots of abrt reports while wireless connection is in use. Connection actually seems to work, but the steady notifications are somewhat annoying. I've never experienced this before 3.9.2 though; up to 3.8.11, wireless worked flawlessly, so there must have been introduced some kind of issue with the latest kernel updates.

Additional info:
WARNING: at drivers/net/wireless/ath/carl9170/tx.c:992 carl9170_op_tx+0x711/0x8a0 [carl9170]()
Hardware name: System Product Name
Modules linked in: ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE be2iscsi iscsi_boot_sysfs bnx2i ip6table_mangle cnic uio ip6t_REJECT cxgb4i nf_conntrack_ipv6 nf_defrag_ipv6 cxgb4 iptable_nat nf_nat_ipv4 nf_nat cxgb3i iptable_mangle cxgb3 mdio nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack libcxgbi ebtable_filter bnep ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core bluetooth ebtables iscsi_tcp libiscsi_tcp ip6table_filter libiscsi scsi_transport_iscsi ip6_tables arc4 snd_hda_codec_hdmi snd_hda_codec_via snd_hda_intel snd_hda_codec snd_hwdep acpi_cpufreq carl9170 snd_seq snd_seq_device snd_pcm vhost_net tun mperf ath snd_page_alloc mac80211 snd_timer iTCO_wdt coretemp iTCO_vendor_support macvtap macvlan snd cfg80211 lpc_ich kvm_intel microcode rfkill i2c_i801 soundcore kvm serio_raw asus_atk0110 mfd_core joydev uinput ata_generic pata_acpi radeon i2c_algo_bit drm_kms_helper r8169 ttm pata_marvell mii drm i2c_core sunrpc
Pid: 550, comm: chronyd Not tainted 3.9.4-200.fc18.x86_64 #1
Call Trace:
 [<ffffffff8105f125>] warn_slowpath_common+0x75/0xa0
 [<ffffffff8105f16a>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa045a311>] carl9170_op_tx+0x711/0x8a0 [carl9170]
 [<ffffffffa038bb84>] __ieee80211_tx+0x124/0x370 [mac80211]
 [<ffffffffa038d503>] ieee80211_tx+0xe3/0x110 [mac80211]
 [<ffffffffa038d5da>] ieee80211_xmit+0xaa/0x110 [mac80211]
 [<ffffffffa038e531>] ieee80211_subif_start_xmit+0xbc1/0xdd0 [mac80211]
 [<ffffffff815521af>] ? dev_queue_xmit_nit+0x1af/0x220
 [<ffffffff81554cf8>] dev_hard_start_xmit+0x278/0x4e0
 [<ffffffff81573260>] sch_direct_xmit+0xf0/0x1c0
 [<ffffffff81555130>] dev_queue_xmit+0x1d0/0x460
 [<ffffffff8158ed97>] ip_finish_output+0x2b7/0x3c0
 [<ffffffff8158f7c5>] ip_output+0x55/0x90
 [<ffffffff8158ef4a>] ? __ip_local_out+0xaa/0xb0
 [<ffffffff8158ef79>] ip_local_out+0x29/0x30
 [<ffffffff815902a9>] ip_send_skb+0x19/0x50
 [<ffffffff815b64b0>] udp_send_skb+0x150/0x3a0
 [<ffffffff8158d380>] ? ip_copy_metadata+0x1a0/0x1a0
 [<ffffffff815b7efd>] udp_sendmsg+0x2fd/0xa10
 [<ffffffff811b2600>] ? __pollwait+0xf0/0xf0
 [<ffffffff812a27d5>] ? sock_has_perm+0x75/0x90
 [<ffffffff811b2602>] ? pollwake+0x2/0x70
 [<ffffffff815c3023>] inet_sendmsg+0x63/0xb0
 [<ffffffff812a2903>] ? selinux_socket_sendmsg+0x23/0x30
 [<ffffffff81539de0>] sock_sendmsg+0xb0/0xe0
 [<ffffffff81198858>] ? mem_cgroup_charge_common+0xa8/0x120
 [<ffffffff8153b7ec>] __sys_sendmsg+0x3ac/0x3c0
 [<ffffffff811b33fd>] ? core_sys_select+0x26d/0x320
 [<ffffffff8166562c>] ? __do_page_fault+0x25c/0x4f0
 [<ffffffff8101b3e9>] ? read_tsc+0x9/0x20
 [<ffffffff810b19ec>] ? ktime_get_ts+0x4c/0xf0
 [<ffffffff811b27c5>] ? poll_select_copy_remaining+0xf5/0x150
 [<ffffffff8153d7b9>] sys_sendmsg+0x49/0x90
 [<ffffffff81669f59>] system_call_fastpath+0x16/0x1b
Comment 1 Karsten Stöckmann 2013-05-26 04:08:06 EDT
Created attachment 753257 [details]
File: dmesg
Comment 2 Stanislaw Gruszka 2013-06-21 07:03:17 EDT
We have patch for that on 3.10 but it was not CCed to -stable and this fix is also needed for 3.9.

commit 5f34608fa2acbfef5a06d0072a978c9943c28a2d
Author: Christian Lamparter <chunkeey@googlemail.com>
Date:   Fri Feb 22 01:30:44 2013 +0100

    carl9170: fix frame drop and WARN due to minstrel_ht change
Comment 3 Stanislaw Gruszka 2013-06-21 07:15:32 EDT
Created attachment 763762 [details]
0001-carl9170-fix-frame-drop-and-WARN-due-to-minstrel_ht-.patch

Fix for this issue, unmodified upstream commit which apply cleanly on 3.9.
Comment 4 Stanislaw Gruszka 2013-06-21 07:17:36 EDT
Josh, please commit above patch as fix for this bug. I just posted it to -stable as well.
Comment 5 Josh Boyer 2013-06-21 09:10:13 EDT
Applied.  Thanks!
Comment 6 Fedora Update System 2013-06-27 18:15:24 EDT
kernel-3.9.8-300.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.9.8-300.fc19
Comment 7 Fedora Update System 2013-06-29 11:24:43 EDT
Package kernel-3.9.8-300.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.9.8-300.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11901/kernel-3.9.8-300.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-06-29 12:08:28 EDT
kernel-3.9.8-200.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.9.8-200.fc18
Comment 9 Fedora Update System 2013-06-30 21:39:56 EDT
kernel-3.9.8-300.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-07-05 15:05:06 EDT
kernel-3.9.9-201.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.9.9-201.fc18
Comment 11 Fedora Update System 2013-07-11 23:11:09 EDT
kernel-3.9.9-201.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.