Bug 967309 - packstack is not able to install and configure heat
packstack is not able to install and configure heat
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
high Severity unspecified
: beta
: 4.0
Assigned To: Martin Magr
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 08:55 EDT by Attila Fazekas
Modified: 2013-12-19 19:03 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.6.dev763.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:03:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
packstack logs (DEBUG) (52.97 KB, text/x-log)
2013-11-14 12:45 EST, Nir Magnezi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 43716 None None None Never
OpenStack gerrit 46945 None None None Never

  None (edit)
Description Attila Fazekas 2013-05-26 08:55:40 EDT
packstack does not able to install and configure heat.

openstack-packstack-2013.1.1-0.7.dev580.el6ost.noarch
Comment 4 Nir Magnezi 2013-11-14 12:44:11 EST
Martin,

I tried to verify this fix as follows:

# packstack --allinone --os-heat-install=y --os-heat-cloudwatch-install=y --os-heat-cfn-install=y -d

This resulted an error:

ERROR : Error appeared during Puppet run: 10.35.160.75_keystone.pp
err: /Stage[main]/Keystone/Exec[keystone-manage db_sync]: Failed to call refresh: keystone-manage db_sync returned 1 instead of one of [0] at /var/tmp/packstack/a89224cfa84f46ed94885a996b18ac2a/modules/keystone/manifests/init.pp:199

I tried to run keystone-manage db_sync manually and it seems like mysql-server is not installed at all. (mysqld service is absent).

I will attach the packstack log at the following comment.
Let me know if I should re-open this bug.
Comment 5 Nir Magnezi 2013-11-14 12:45:01 EST
Created attachment 824083 [details]
packstack logs (DEBUG)
Comment 6 Scott Lewis 2013-11-19 11:54:48 EST
Auto adding >= MODIFIED bugs to beta
Comment 7 Nir Magnezi 2013-11-28 09:58:00 EST
Verified NVR:


Verification Steps (Post installation):
=======================================

1. All heat services are up.
# for i in api api-cfn api-cloudwatch engine ; do service openstack-heat-$i status ; done
heat-api (pid  21579) is running...
heat-api-cfn (pid  24254) is running...
heat-api-cloudwatch (pid  22955) is running...
heat-engine (pid  21620) is running...

2. No errors found in heat logs.

3. Heat API services are configured in keystone:
# keystone service-list | grep heat
| 31a30c85ba7b4c5fae5611f5c1bedfc2 |    heat    | orchestration  |            Heat API            |
| 6e6196ec4f0f48f4abc6f076d2df3f81 |  heat-cfn  | cloudformation |    Heat CloudFormation API     |

4. Heat is available via Horizon.
Comment 8 Nir Magnezi 2013-11-28 09:58:58 EST
Forgot to specify the NVR: openstack-packstack-2013.2.1-0.11.dev847.el6ost.noarch
Comment 11 errata-xmlrpc 2013-12-19 19:03:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.