Bug 967325 - yum groupinstall 'Development Tools' fails dependancy checks on new installation of Fedora 18
yum groupinstall 'Development Tools' fails dependancy checks on new installat...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Grubb
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 12:12 EDT by entransic
Modified: 2013-05-27 04:02 EDT (History)
7 users (show)

See Also:
Fixed In Version: audit-2.3-2.fc18.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 04:02:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description entransic 2013-05-26 12:12:53 EDT
Description of problem:
running 'yum groupinstall 'Development Tools" fails with a dependancy conflict on a new installation of Fedora 18.0

Version-Release number of selected component (if applicable):
18.0

How reproducible:
very

Steps to Reproduce:
1.fresh install of Fedora 18.0 from iso into oracle virtualbox
2.sudo yum groupinstall 'Development Tools'
3.

Actual results:
file /usr/lib64/audit from install of glibc-2.16-31.fc18.x86_64 conflicts with file from package audit-2.2.1-2.fc18.x86_64

Expected results: 
installation would complete since it is a group package

Additional info:
a workaround is:

yum install audio
yum groupinstall 'Development Tools'
Comment 1 entransic 2013-05-26 12:22:15 EDT
the workaround was mis-typed.

yum install audit
yum groupinstall 'Development Tools'
Comment 2 Zdeněk Pavlas 2013-05-27 03:59:16 EDT
This is a packaging error, the directory is packaged by both packages, but with different permissions.  Probably "audit" is to blame, it didn't package it in previous version:

[~/Downloads]$ rpm -ql -p audit-2.3-2.fc18.x86_64.rpm |grep lib64
[~/Downloads]$ rpm -ql -p audit-2.2.1-2.fc18.x86_64.rpm |grep lib64
/usr/lib64/audit
Comment 3 Zdeněk Pavlas 2013-05-27 04:02:04 EDT
Sorry, the newer package is actually correct.

Note You need to log in before you can comment on or make changes to this bug.