Bug 967370 - Couldn't change keyring password
Couldn't change keyring password
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: mate-keyring (Show other bugs)
18
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 17:40 EDT by Per Nystrom
Modified: 2013-09-28 11:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-28 11:51:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of seahorse error (23.75 KB, image/png)
2013-05-26 17:40 EDT, Per Nystrom
no flags Details

  None (edit)
Description Per Nystrom 2013-05-26 17:40:21 EDT
Created attachment 753399 [details]
Screenshot of seahorse error

Description of problem:
I recently upgraded to Fedora 18 and the MATE desktop, and now when I log in I have to manually enter the keyring password.  I understand this can be fixed if I change the keyring password to match my user login password, but when I attempt to do this using Seahorse I get "Couldn't change keyring password" -- see attached screen shot.

Version-Release number of selected component (if applicable):
$ rpm -q seahorse
seahorse-3.6.3-1.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start seahorse
2. Right click on the login keyring, select change password
3. Error message appears

Actual results:


Expected results:


Additional info:
Comment 1 Stef Walter 2013-05-27 01:47:42 EDT
Mate went and forked gnome-keyring *completely* needlessly. You probably have mate-keyring installed instead of gnome-keyring. This is completely up to the mate guys to fix, if they want seahorse to work with their fork.
Comment 2 Wolfgang Ulbrich 2013-05-27 04:42:26 EDT
Which desktop manager you use?
Is there a any login keyring file in ~.config/mate/keyrings ?
Comment 3 Per Nystrom 2013-05-28 11:17:03 EDT
I switched to lightdm after finding out that the default gdm was not reacting to things like shutting the laptop lid under MATE.  Since then, the prompts for the keyring password after login have stopped -- though I'm not sure if the two are related.  However, I do still get the same error message in seahorse if I try to change the keyring password.

There is a login keyring file in this directory:

$ ls ~/.config/mate/keyrings
login.keyring  user.keystore
Comment 4 Wolfgang Ulbrich 2013-05-28 17:42:13 EDT
Using lightdm is a good choice in this case, because lightdm did the the pam mate-keyring authorization for MATE, without them no login key is writen to ~/.config/mate/keyrings.
@seahorse
Maybe there is a conflict with the old login keyrings stored in a directory from gnome. But i don't know the directory.
I suggest to delete all login.keyring  user.keystore in user directory.
After a logout/login you will find new keys in ~/.config/mate/keyrings.
Maybe this helps.

In general seahorse is working in my MATE session and i can change the password from my keys.
Comment 5 Wolfgang Ulbrich 2013-05-29 08:27:26 EDT
@Stef Walter

Is 'org.gnome.keyring.InternalUnsupportedGuiltRiddenInterface' a gsetting key or dbus stuff?

@Per Nystrom
Did you uninstalled gnome-keyring?
gnome-keyring is also needed in MATE, some applications need them, ie. network-manager for storing the wifi password.
Comment 6 Per Nystrom 2013-05-29 11:17:53 EDT
@Wolfgang Ulbrich

I did not uninstall gnome-keyring.  Regarding your suggestion to remove the old keyrings, I will try that and let you know.
Comment 7 Stef Walter 2013-06-11 12:49:26 EDT
(In reply to Wolfgang Ulbrich from comment #5)
> @Stef Walter
> 
> Is 'org.gnome.keyring.InternalUnsupportedGuiltRiddenInterface' a gsetting
> key or dbus stuff?

It's an internal gnome-keyring dbus interface.
Comment 8 Wolfgang Ulbrich 2013-07-09 13:14:41 EDT
@ Stef Walter
There is a plan from MATE to switch to gnome-keyring 'IF IT WORKS FOR OTHER DESKTOPS'
First tests shows me we run in probs with ssh.
Is there a way to communicate with you about this per irc chanel or email?
Comment 9 Stef Walter 2013-07-09 16:29:03 EDT
Sounds good. I'm stefw@gnome.org or stefw on IRC at gimpnet. Talk to you soon.
Comment 10 Wolfgang Ulbrich 2013-09-12 15:30:59 EDT
Does this issue still exits?
Comment 11 Wolfgang Ulbrich 2013-09-28 11:51:43 EDT
no user action since 5 month!

Note You need to log in before you can comment on or make changes to this bug.