Bug 967373 - SELinux is preventing /usr/bin/login from 'read' accesses on the file /var/log/lastlog.
SELinux is preventing /usr/bin/login from 'read' accesses on the file /var/lo...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:54b278c015886c7eb837ab25239...
:
: 967374 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 18:10 EDT by Moez Roy
Modified: 2013-07-24 20:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.11.1-98.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 20:37:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-05-26 18:10:52 EDT
Description of problem:
SELinux is preventing /usr/bin/login from 'read' accesses on the file /var/log/lastlog.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label. 
/var/log/lastlog default label should be lastlog_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /var/log/lastlog

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that login should be allowed read access on the lastlog file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep login /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:local_login_t:s0-s0:c0.c1023
Target Context                system_u:object_r:xdm_log_t:s0
Target Objects                /var/log/lastlog [ file ]
Source                        login
Source Path                   /usr/bin/login
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           util-linux-2.22.2-6.fc18.x86_64
Target RPM Packages           setup-2.8.57-1.fc18.noarch util-
                              linux-2.22.2-6.fc18.x86_64
Policy RPM                    selinux-policy-3.11.1-96.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.3-201.fc18.x86_64 #1 SMP Tue
                              May 21 17:02:24 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-26 15:00:20 PDT
Last Seen                     2013-05-26 15:00:20 PDT
Local ID                      e0767682-580c-407e-8cb8-18c48d789c9c

Raw Audit Messages
type=AVC msg=audit(1369605620.59:294): avc:  denied  { read } for  pid=2045 comm="login" name="lastlog" dev="dm-0" ino=917538 scontext=system_u:system_r:local_login_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_log_t:s0 tclass=file


type=SYSCALL msg=audit(1369605620.59:294): arch=x86_64 syscall=open success=no exit=EACCES a0=7f94e607a304 a1=0 a2=3e8 a3=1d items=0 ppid=1 pid=2045 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=3 tty=tty3 comm=login exe=/usr/bin/login subj=system_u:system_r:local_login_t:s0-s0:c0.c1023 key=(null)

Hash: login,local_login_t,xdm_log_t,file,read

audit2allow

#============= local_login_t ==============
allow local_login_t xdm_log_t:file read;

audit2allow -R
require {
	type local_login_t;
	type xdm_log_t;
	class file read;
}

#============= local_login_t ==============
allow local_login_t xdm_log_t:file read;


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-28 05:19:02 EDT
*** Bug 967374 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-05-29 06:24:09 EDT
Please execute

# restoreco -R -v /var/log/lastlog

Added fixes.
Comment 3 Fedora Update System 2013-06-27 09:33:20 EDT
selinux-policy-3.11.1-98.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-98.fc18
Comment 4 Fedora Update System 2013-06-28 02:07:34 EDT
Package selinux-policy-3.11.1-98.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-98.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11859/selinux-policy-3.11.1-98.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-24 20:37:24 EDT
selinux-policy-3.11.1-98.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.