Bug 967378 - SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jre/bin/java from 'write' accesses on the file /home/frieben/.icedtea/cache/recently_used.
SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jre/bin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a106c072fe3e9a3c56f3abbab20...
:
: 967708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 18:54 EDT by Joachim Frieben
Modified: 2013-06-23 23:28 EDT (History)
9 users (show)

See Also:
Fixed In Version: selinux-policy-3.10.0-170.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-23 23:28:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2013-05-26 18:54:52 EDT
Description of problem:
Checked Java version at http://www.java.com.
SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jre/bin/java from 'write' accesses on the file /home/frieben/.icedtea/cache/recently_used.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that java should be allowed write access on the recently_used file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep java /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /home/frieben/.icedtea/cache/recently_used [ file
                              ]
Source                        java
Source Path                   /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jr
                              e/bin/java
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           java-1.7.0-openjdk-1.7.0.19-2.3.9.3.fc17.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-169.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.6.11-5.fc17.x86_64 #1 SMP Tue
                              Jan 8 21:40:51 UTC 2013 x86_64 x86_64
Alert Count                   42
First Seen                    2013-05-27 00:39:25 CEST
Last Seen                     2013-05-27 00:44:57 CEST
Local ID                      6d68b44f-ffc9-460f-9b6e-b86a9cfc04e4

Raw Audit Messages
type=AVC msg=audit(1369608297.670:108): avc:  denied  { write } for  pid=2026 comm="java" name="recently_used" dev="dm-2" ino=1577650 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file


type=SYSCALL msg=audit(1369608297.670:108): arch=x86_64 syscall=open success=no exit=EACCES a0=7fc388000b60 a1=241 a2=1b6 a3=6365722f65686361 items=0 ppid=1452 pid=2026 auid=1001 uid=1001 gid=100 euid=1001 suid=1001 fsuid=1001 egid=100 sgid=100 fsgid=100 tty=(none) ses=2 comm=java exe=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jre/bin/java subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: java,mozilla_plugin_t,user_home_t,file,write

audit2allow

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_t:file write;

audit2allow -R

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_t:file write;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.6.11-5.fc17.x86_64
type:           libreport

Potential duplicate: bug 907049
Comment 1 Klaas Zwaan 2013-05-28 01:50:36 EDT
Description of problem:
Start to work from home and logging in into my account at my office.
Yesterday I have installed the new updates for Fedora 17. Last week it worked just fine.

Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.13-100.fc17.x86_64
type:           libreport
Comment 2 Miroslav Grepl 2013-05-28 06:11:32 EDT
*** Bug 967708 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2013-05-28 06:14:09 EDT
Please execute

# chcon -R -t mozilla_home_t /home/frieben/.icedtea

which will fix it for now.
Comment 4 Graeme Frear 2013-06-03 13:03:04 EDT
Description of problem:
Trying to ssh to console with Right scale

Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.13-100.fc17.x86_64
type:           libreport
Comment 5 Cesar Eduardo Barros 2013-06-06 08:02:46 EDT
Description of problem:
To reproduce, open https://www2.bancobrasil.com.br/aapf/login.jsp?aapf.IDH=sim&perfil=1 or similar URLs with java plugin enabled, as a restricted user.

Additional info:
hashmarkername: setroubleshoot
kernel:         3.9.4-100.fc17.x86_64
type:           libreport
Comment 6 Fedora Update System 2013-06-07 03:00:32 EDT
selinux-policy-3.10.0-170.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-170.fc17
Comment 7 Fedora Update System 2013-06-07 19:27:29 EDT
Package selinux-policy-3.10.0-170.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-170.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10302/selinux-policy-3.10.0-170.fc17
then log in and leave karma (feedback).
Comment 8 Andreas Fischer 2013-06-12 09:38:42 EDT
Description of problem:
zu Bug 967843!

Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.13-100.fc17.x86_64
type:           libreport
Comment 9 Andreas Fischer 2013-06-12 09:44:22 EDT
Description of problem:
zu Bug 967843

Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.13-100.fc17.x86_64
type:           libreport
Comment 10 Klaas Zwaan 2013-06-18 02:07:18 EDT
Description of problem:
Starting to work from home. Just logged in into my virtual workplace.

Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.13-100.fc17.x86_64
type:           libreport
Comment 11 Steven Moyse 2013-06-20 00:28:22 EDT
Description of problem:
Run IBM DownloadDirector from firefox

Additionally getting this when trying to generate local policy.

[root@jupiter ~]# grep java /var/log/audit/audit.log | audit2allow -M mypol
Nothing to do

Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.13-100.fc17.x86_64
type:           libreport
Comment 12 Daniel Walsh 2013-06-20 13:52:21 EDT
Run restorecon -R -v  ~/
Comment 13 Steven Moyse 2013-06-20 22:22:14 EDT
restorecon -R -v  ~/

Actually broke some previous fixes.

I had to run:

chcon -R -t mozilla_home_t /home/smoyse/DownloadDirector
Comment 14 Miroslav Grepl 2013-06-21 03:21:06 EDT
We don't have default labeling for ~/DownloadDirector.

Did you create this directory?
Comment 15 Fedora Update System 2013-06-23 23:28:31 EDT
selinux-policy-3.10.0-170.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.