Bug 967387 - anaconda refuse '/usr/bin' as a valid mount point (it installs ok, but then id does not boot normally)
anaconda refuse '/usr/bin' as a valid mount point (it installs ok, but then i...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 20:21 EDT by Reartes Guillermo
Modified: 2013-05-31 20:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 20:00:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first boot after installing with a separate /usr/bin partition. (36.24 KB, image/png)
2013-05-26 20:21 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-05-26 20:21:19 EDT
Created attachment 753433 [details]
first boot after installing with a separate /usr/bin partition.

Description of problem:

Create a separate /usr/bin partition. I created a big one (1gb) and i was able to install F19b RC4. (Smaller partitions results in YumRPMTransError: Could not run transaction.)

After installation, systemd ask for maintenance mode. (sreenshot).

Version-Release number of selected component (if applicable):
F19b RC4 (19.30-1)

How reproducible:
always

Steps to Reproduce:
1. Configure your favorite anaconda settings.
2. Enter custom partitoning
3. Create a 1gb /usr/bin mount point (ext4)
4. Create the other mount points. (/boot,swap,/)
5. Install F19b RC4
6. Reboot, systemd ask for maintenance mode

Actual results:
first boot after installation fails, due to /usr/bin being a separate
filesystem. (broken symlinks?)

Expected results:
refuse to accept '/usr/bin' as a valid mount point (or fix booting with such setup)

Additional info:
smaller /usr/bin are also accepted and result in a stop error and an aborted installation.
Comment 1 Brian Lane 2013-05-31 20:00:37 EDT
A separate /usr/bin isn't supported. We can't protect the user from every little thing they may try to do.

Note You need to log in before you can comment on or make changes to this bug.