Bug 9674 - adjtimex -t option ambiguous (in man-page)
adjtimex -t option ambiguous (in man-page)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: adjtimex (Show other bugs)
6.2
alpha Linux
medium Severity low
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-22 11:40 EST by Brock Organ
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-29 16:38:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brock Organ 2000-02-22 11:40:43 EST
running adjtimex with -t causes error message:

[root@ultra1 test]# adjtimex -t 1
adjtimex: option `-t' is ambiguous
For valid options, try 'adjtimex --help'
[root@ultra1 test]# adjtimex --help

Usage: adjtimex  [OPTION]...
Mandatory or optional arguments to long options are mandatory or optional
for short options too.

Get/Set Kernel Time Parameters:
       -p, --print               print values of kernel time variables
       -t, --tick val            set the kernel tick interval in usec
       -f, --frequency newfreq   set system clock frequency offset
       -s, --singleshot adj      slew the system clock by adj usec
       -o, --offset adj          add a time offset of adj usec
       -m, --maxerror val        set maximum error (usec)
       -e, --esterror val        set estimated error (usec)
       -T, --timeconstant val    set phase locked loop time constant

Estimate Systematic Drifts:
       -c, --compare[=count]     compare system and CMOS clocks
       -a, --adjust[=count]      adjust system clock per CMOS clock
       -i, --interval tim        set clock comparison interval (sec)
       -l, --log[=file]          log current times to file
           --host timeserver     query the timeserver
       -w, --watch               get current time from user
       -r, --review[=file]       review clock log file, estimate drifts
       -u, --utc                 the CMOS clock is set to UTC

Informative Output:
           --help                print this help, then exit
       -v, --version             print adjtimex program version, then exit
[root@ultra1 test]#
Comment 1 Cristian Gafton 2000-03-03 12:13:59 EST
Fixed in the devel tree
Comment 2 Brock Organ 2000-03-14 09:21:59 EST
The latest adjtimex still fails using the -t option on the alpha...

[root@test162 /root]# rpm -q adjtimex
adjtimex-1.9-3

[root@test162 /root]# adjtimex -t 9999
adjtimex: Invalid argument
[root@test162 /root]# adjtimex --tick 9999
adjtimex: Invalid argument
[root@test162 /root]#
Comment 3 Cristian Gafton 2000-03-29 12:09:59 EST
Works for me.
Comment 4 Brock Organ 2000-03-29 13:25:59 EST
as Cristian showed me, adjtimex -t 9999 is not valid on the alpha; basically,
the value that should've been tried instead of 9999 is 999 ... changes to the
adjtimex man page (alpha version ONLY) to the valid tick range will resolve this
issue:

from the man page:

     -t val, --tick val
Set the number of microseconds that should be added to the system time for each
kernel tick interrupt.  There are supposed to be 100 ticks per second, so val
should be close to 10000.  Increasing val by 1 speeds up the system clock by
about 100 ppm, or 8.64 sec/day. tick must be in the range 9000...11000.

change the range values on alpha to 900...1100
Comment 5 Glen Foster 2000-03-30 12:17:59 EST
I am re-opening this defect because the man-page needs to be changed on the
Alpha to reflect that the parameter to -t is DIFFERENT on that architecture.

Low-weight or not, the man-page still has a bug; defect is OPEN until fixed.
Comment 6 Preston Brown 2001-01-29 16:38:12 EST
fixed in 1.11-4 and later.

Note You need to log in before you can comment on or make changes to this bug.