Bug 967408 - z88dk includes non-free code
z88dk includes non-free code
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: z88dk (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-05-27 00:39 EDT by mejiko
Modified: 2015-07-09 17:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: z88dk-1.10.1-8.20150709cvs.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-09 17:46:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 709520 None None None Never
GNU Savannah 39054 None None None Never

  None (edit)
Description mejiko 2013-05-27 00:39:38 EDT
Hello.

SRC RPM is "z88dk-1.10.1-1.fc18.src.rpm"

z88dk included non free code. 
Please See Debian bug number "709520" details.

I think that this package be affected by debian bug number "709520". (I view and checked this source package)

Suggests:


1. Remove non-free code and rebuild.
2. Replace to Fedora free(acceptable licensed) file.
3. Remove Fedora repos.


Thanks.


Reference:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709520
https://savannah.nongnu.org/bugs/?func=detailitem&item_id=39054
Comment 1 mejiko 2013-05-27 00:40:37 EDT
Blocking FE-Legal, This is license problem.
Comment 2 Kevin Kofler 2013-05-27 09:10:31 EDT
Where's the report to upstream z88dk.org? (They have a bug tracker at SourceForge, a web-based forum and mailing lists, I don't see any report of this issue anywhere there.)
Comment 3 Tom "spot" Callaway 2013-05-28 10:59:44 EDT
Reported upstream here:
http://www.z88dk.org/forum/viewtopic.php?pid=8504

This is a valid issue.
Comment 4 Kevin Kofler 2013-05-28 11:25:26 EDT
I don't doubt that it's valid. If I had caught this during review, I'd have failed it instantly. Sadly, I was neither the submitter nor the reviewer, I only picked this thing up after it got orphaned.

I need to have a look at how easy it is to get rid of the offending files.
Comment 5 Kevin Kofler 2013-05-28 11:36:26 EDT
For the Z80 emulation core under test/machine, I can just zap the testsuite altogether. The specfile isn't running it in the first place, and it doesn't test all that much.

The ozcustomisr.asm issue is more annoying. The sledgehammer approach would be to nuke the whole OZ-7xx target. I think I'll wait a couple days for upstream to double-check with the author, if you're OK with that.
Comment 6 Tom "spot" Callaway 2013-05-29 08:46:13 EDT
Upstream is making good progress in the forum thread. We can wait to see if they can fix it entirely on their end before applying workarounds.
Comment 7 Kevin Kofler 2013-05-29 18:51:58 EDT
OK, agreed. I'll keep watching this, feel free to poke me if I forget. :-)
Comment 8 mejiko 2013-08-04 22:45:24 EDT
Fedora 19 version is not resolved this problem.
Comment 9 mejiko 2013-10-15 01:15:26 EDT
I see current upstream CVS, There non-free files is removed. 

http://z88dk.cvs.sourceforge.net/viewvc/z88dk/z88dk/test/machine/Z80/
http://z88dk.cvs.sourceforge.net/viewvc/z88dk/z88dk/libsrc/oz/ozinterrupt/

I suggests that upgrade current CVS version.

Thanks.
Comment 10 mejiko 2014-03-15 06:05:38 EDT
Changed to rawhide. 

Is this bug is resolved ?
How it this bug current status ?

Thanks.


Reference:

https://trisquel.info/en/issues/8717
Comment 11 Kevin Kofler 2015-02-21 19:31:26 EST
The issue is resolved in upstream CVS HEAD, but there has been no release with the fix.
Comment 12 Jaroslav Reznik 2015-03-03 09:57:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 13 Kevin Kofler 2015-07-09 17:46:22 EDT
The offending files are gone in the current upstream snapshot that I built for Rawhide.

Note You need to log in before you can comment on or make changes to this bug.