This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 967411 - fpc included non-free code
fpc included non-free code
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fpc (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joost van der Sluis
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-05-27 00:42 EDT by mejiko
Modified: 2013-05-27 15:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 15:37:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mejiko 2013-05-27 00:42:17 EDT
Hello.

SRC RPM is : "fpc-2.6.0-3.fc18.src.rpm".

fpc included non-free code.


Files:


fpcbuild-2.6.0/fpcsrc/packages/opengl/src/glu.pp

This code license is proprietary, Its non-free.


fpcbuild-2.6.0/fpcsrc/packages/opengl/src/glut.pp

This code license freely distributable, but do not allow modify. Its non-free.


fpcbuild-2.6.0/fpcsrc/packages/opengl/src/freeglut.pp
fpcbuild-2.6.0/fpcsrc/packages/opengl/src/glext.pp

This code is not license infomation. Its non-free.


Suggests:

1. remove non-free code and rebuild.
2. replace fedora free (acceptable licensed) files.
3. remove fedora repos.

Thanks.



Reference:

http://www.mail-archive.com/gnu-linux-libre@nongnu.org/msg01200.html
Comment 1 mejiko 2013-05-27 00:42:48 EDT
Blocking FE-Legal, This is license problem.
Comment 2 Joost van der Sluis 2013-05-27 13:55:05 EDT
It' a header file. Afaik it is not possible to claim copyright on such headers. (Since it's not a creative work) It would imply that no-one could use opengl in any open-source project at all.

The copyright-information is in those files, because those files are automatically generated from the original header-files. The comments are copied.

I'll ask upstream what to do. And maybe someone from legal can help?
Comment 3 Joost van der Sluis 2013-05-27 14:27:12 EDT
Besides, I find it hard to call this 'non-free' It's basically a BSD-license. Quoted from glu.pp:

  * Permission is hereby granted, free of charge, to any person obtaining a
   * copy of this software and associated documentation files (the "Software"),
   * to deal in the Software without restriction, including without limitation
   * the rights to use, copy, modify, merge, publish, distribute, sublicense,
   * and/or sell copies of the Software, and to permit persons to whom the
   * Software is furnished to do so, subject to the following conditions:
   *
   * The above copyright notice including the dates of first publication and
   * either this permission notice or a reference to
   * http://oss.sgi.com/projects/FreeB/
   * shall be included in all copies or substantial portions of the Software.
Comment 4 Joost van der Sluis 2013-05-27 15:37:21 EDT
Seems that this is already changed in fpc version 2.6.0, which is packaged in F18. For more information see this upstream bug: http://bugs.freepascal.org/view.php?id=20200

Note You need to log in before you can comment on or make changes to this bug.