This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 967416 - audacity included non-free codes.
audacity included non-free codes.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Manuel F Martinez
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-05-27 00:50 EDT by mejiko
Modified: 2013-05-28 10:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 10:08:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 631068 None None None Never
GNU Savannah 33410 None None None Never

  None (edit)
Description mejiko 2013-05-27 00:50:44 EDT
Hello.


SRC RPM is: "audacity-2.0.3-1.fc18.src.rpm"


audacity include non-free code.


Files:

audacity-src-2.0.3/lib-src/libnyquist/nyquist/xlisp/*

This license is "non-commercial use only", Its non-free.


Suggests:

1. remove non-free code and rebuild.
2. replace fedora free (acceptable licensed) files.
3. remove fedora repos.

Thanks.


Reference:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=631068
https://savannah.nongnu.org/bugs/?func=detailitem&item_id=33410
Comment 1 mejiko 2013-05-27 00:51:34 EDT
Blocking FE-Legal, This is license problem.
Comment 2 Tom "spot" Callaway 2013-05-28 10:08:20 EDT
The header files have simply not been updated to reflect the change in license for these files to BSD. The license.txt in the nyquist subdir has the correct licensing terms. This is NOTABUG, because we know the BSD license applies here. (Debian had the same stance and closed this bug out once the new license text was provided by upstream).

That said, Hans, please ask audacity upstream to correct the header files under lib-src/libnyquist/nyquist to either have the proper license (or simply refer to license.txt).

I've also committed a change in rawhide to include the nyquist readme.txt and license.txt to eliminate ambiguity here.

Note You need to log in before you can comment on or make changes to this bug.