Bug 967417 - bacula included non-free code
Summary: bacula included non-free code
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bacula   
(Show other bugs)
Version: 18
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-Legal
TreeView+ depends on / blocked
 
Reported: 2013-05-27 04:53 UTC by mejiko
Modified: 2013-06-06 02:22 UTC (History)
8 users (show)

Fixed In Version: bacula-5.2.13-11.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 17:46:49 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Savannah 35854 None None None Never
Debian BTS 658326 None None None Never

Description mejiko 2013-05-27 04:53:28 UTC
Hello.

SRC RPM is: "bacula-5.2.13-9.fc18.src.rpm"

bacula included non-free code.


Files:

bacula-5.2.13/src/lib/sha1.*

This code license is "freely distributable", but do not allow modify.
Its non-free.


Suggests:

1. remove non-free code and rebuild.
2. replace fedora free (acceptable licensed) files.
3. remove fedora repos.


Thanks.


Reference:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=658326
https://savannah.nongnu.org/bugs/?35854

Comment 1 mejiko 2013-05-27 04:54:19 UTC
Blocking FE-Legal, This is license problem.

Comment 2 Simone Caronni 2013-05-27 09:47:21 UTC
Debian patch which removes sha1 from the sources:

http://anonscm.debian.org/gitweb/?p=pkg-bacula/bacula.git;a=blob_plain;f=debian/patches/switch-nonfree-sha1-to-openssl.patch;hb=6c562cfdaffd730c796518233f0d97da08a3891b

This will prevent building Bacula without OpenSSL support but with SHA1 enabled. This is not our case since in Fedora it was always shipped linked to OpenSSL; so I think the fix is pretty simple.

Regards,
--Simone

Comment 3 Petr Hracek 2013-05-27 12:25:41 UTC
I have just another question.

In bacula package are also md5.c and md5.h files.
They should be also modified and removed, right?

Comment 4 Petr Hracek 2013-05-28 11:16:18 UTC
sha1 files were removed.
Makefile.in file was modified accordingly.
scm-commit (http://lists.fedoraproject.org/pipermail/scm-commits/Week-of-Mon-20130527/1028300.html) -> MODIFIED

In build log can be seen that sha1.c file is not build up anymore.
OpenSSL is enabled by default.

Comment 5 Fedora Update System 2013-05-28 11:31:08 UTC
bacula-5.2.13-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/bacula-5.2.13-11.fc19

Comment 6 Fedora Update System 2013-05-28 11:31:49 UTC
bacula-5.2.13-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bacula-5.2.13-11.fc18

Comment 7 Tom "spot" Callaway 2013-05-28 12:50:06 UTC
Petr, the md5 source code is fine to keep.

Comment 8 Fedora Update System 2013-05-28 13:31:10 UTC
bacula-5.2.13-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/bacula-5.2.13-11.fc17

Comment 9 Fedora Update System 2013-05-28 16:16:46 UTC
Package bacula-5.2.13-11.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bacula-5.2.13-11.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9468/bacula-5.2.13-11.fc19
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2013-06-06 01:33:46 UTC
bacula-5.2.13-11.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-06-06 01:44:25 UTC
bacula-5.2.13-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-06-06 02:22:50 UTC
bacula-5.2.13-11.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.