Bug 967431 - RFE: Improve the [CopyTrans] options page, for clarity and accommodating the review feature
RFE: Improve the [CopyTrans] options page, for clarity and accommodating the ...
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Luke Brooker
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 02:36 EDT by Ding-Yi Chen
Modified: 2016-04-18 05:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-30 21:24:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Copy Trans screenshot (42.26 KB, image/png)
2013-05-28 00:25 EDT, Alex Eng
no flags Details
Proposed future mockup of copy trans options (92.35 KB, image/jpeg)
2013-05-30 22:18 EDT, Luke Brooker
no flags Details

  None (edit)
Description Ding-Yi Chen 2013-05-27 02:36:25 EDT
Description of problem:
Now there are 5 states as result of enabling review feature, they are:
"Untranslated", "Fuzzy", "Rejected", "Translated" and "Approved".

To avoid confusion, the copytrans option page should do following change:
1. Clearly states that all rules will be evaluated, and the "lowest" state will be choose.
2. Change the "Reject" to "Discard".
3. Rule 5 should be: if everything match and the translation is approved, then set as "Approved"
4. Rule 6 should be: otherwise set as "Translated".


Version-Release number of selected component (if applicable):
Zanata version 3.0.0-SNAPSHOT (20130523-1440)
Comment 1 Alex Eng 2013-05-28 00:25:43 EDT
Created attachment 753730 [details]
Copy Trans screenshot

Current copy trans screenshot
Comment 2 Luke Brooker 2013-05-30 22:18:22 EDT
Created attachment 755125 [details]
Proposed future mockup of copy trans options

This is an idea of what we could do to simplify the copy trans option screen.

Let me know if I am missing something or this doesn't make sense.
Comment 3 Sean Flanigan 2013-05-31 00:53:34 EDT
That's an improvement on what we've got now.  Unless I'm missing something, it's just a better way of presenting exactly the same options, so it shouldn't be difficult to implement.

But, really, it's still far too complex to explain, to test, to implement.  We need something that doesn't have as many options.  We should make a small number of copytrans profiles which cover normal cases.  Something along these lines:

1. Software (eg gettext, properties)
      Context must match, soft-reject otherwise
      Doc id must match, soft-reject otherwise

2. Software (temporarily ignore doc name due to refactoring)
      Context must match, soft-reject otherwise
      Doc id need not match
      Project must match, soft-reject otherwise

3. Documentation
      TBD

Plus a small number of flags, eg:

1. Copy rejected matches (as Translated for reviewable projects, as Fuzzy for non-reviewable)
2. Copy translations from other projects as Translated
3. Copy translations from other projects as Fuzzy
Comment 4 Carlos Munoz 2013-08-08 21:40:29 EDT
I still think we should allow for detailed customization of the process (Just recently we were able to use copy trans to reuse translations in a very creative way for one of the projects).

But I like the idea of the "predefined" configurations for copy trans. So what if we offer some way to automatically make the right selections for "Software", "Documentation", and "Software (ignore doc name)" for the common cases. We could even hide the "advanced" options until the user specifically asks about them.

BTW, I think Luke's mockup is a great way of conveying the process.
Comment 5 Luke Brooker 2014-03-04 23:28:29 EST
This has been iterated on for the new project screen. A mockup can be seen here:

http://assets-zanata.rhcloud.com/master/projects/mortal-kombat/settings/#tab-vertical-3

I think this can still be improved in the future, but further improvements I have thought of would need more backend changes which can not be included this sprint.
Comment 6 Zanata Migrator 2015-07-30 21:24:37 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-488

Note You need to log in before you can comment on or make changes to this bug.