Bug 967441 - Query doesn't work without other queries defined
Query doesn't work without other queries defined
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Mario Fusco
Tomas David
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 03:24 EDT by Tomas David
Modified: 2014-08-06 16:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:17:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas David 2013-05-27 03:24:50 EDT
Description of problem:
When there is a query with temporal operator in dlr file and no other queries are defined in same file, query doesn't return required results. 

Version-Release number of selected component (if applicable):
Drools 6.0.0.Beta2

How reproducible:
Pull request #201 submited in Drools.

Steps to Reproduce:
1. Write a simple test with one KieSession and two SessionEntryPoints. Into first SessionEntryPoint insert Event at time 0s. Into second SessionEntryPoint insert three event at times 0s, 10s and 20s.
2. Make a drl file with one query, which should returns events from second SessionEntryPoint with time in interval <0s, 9s> after event from first SessionEntryPoint.
3. Run Test.

Actual results:
Zero events are returned.

Expected results:
There should be one event with time 0s.

Additional info:
If more queries are defined, result is correctly one event with time 0s.
Comment 2 Mario Fusco 2013-10-07 12:58:37 EDT
I couldn't reproduce this issue on the master. I am assuming that it has been fixed by a previous commit. I added a unit test to demonstrate that it is working now: https://github.com/droolsjbpm/drools/commit/f6f4543ef
Comment 5 Tomas David 2013-11-28 03:33:17 EST
Verified on BRMS 6.0.0.ER5.

Note You need to log in before you can comment on or make changes to this bug.