Bug 967443 - When editting CSV data provider properties Cancel button doesn't change GUI
When editting CSV data provider properties Cancel button doesn't change GUI
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity low
: ER2
: 6.0.0
Assigned To: David Gutierrez
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 03:29 EDT by Jan Hrcek
Modified: 2014-08-06 16:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Steps to reproduce the problem (463.95 KB, image/png)
2013-05-27 03:29 EDT, Jan Hrcek
no flags Details
Video recording of reproducing steps (4.21 MB, video/webm)
2013-06-20 07:23 EDT, Jan Hrcek
no flags Details
Testing CSV file (259 bytes, text/csv)
2013-06-20 07:23 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-05-27 03:29:43 EDT
Created attachment 753501 [details]
Steps to reproduce the problem

Description of problem:
When Cancel button is pressed during editting CSV file data provider properties - nothing happens. Only Second press of that button takes you back to the list of data providers.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Navigate to "Data providers" page in workspace "Showcase"
2. Click "Create new data provider"
3. Select type "CSV file"
4. Fill in some valid configuration of CSV provider and click Save (see screenshot)
5. On the screen "Editing data provider properties" click the Cancel button

Actual results:
No change is displayed in the GUI after the first click on the Cancel button. To get back it is necessary to click the Cancel button for a second time, which gets you back to the list of data providers.

Expected results:
I would expect either: 
1) get back to the previous "screen" (Creation of data provider). This seems like more logical choice, creating a wizard-like experience. In that case maybe renaming of the cancel button to something like "Back" would be appropriate. 

OR

2) get back to the initial list of data providers (however that would make user entered data for new CSV data provider disappear)

Additional info:
See screensot for explanation.
Comment 1 David Gutierrez 2013-06-13 09:56:37 EDT
We can't reproduce it with the latest version.

Could you please try it again?
In case it fails, please, attach the CSV file you're using.
Comment 2 Jan Hrcek 2013-06-20 07:21:17 EDT
Today I tried with the latest commit ebc3258317 from github master branch.

The problem is still there, no change since I reported it.

Maybe you didn't understand what I meant - I recorded a video of the problem.
See in 00:27, when the Cancel button is clicked, the page is reloaded, but the panel stays in the state of "Editting data provider properties". It is necessary to click Cancel for the secont time (00:31) to actually get back to provider list.

For fullness I attach video of the reproducing steps + testing csv file (which is btw taken from wikipedia)
Comment 3 Jan Hrcek 2013-06-20 07:23:10 EDT
Created attachment 763430 [details]
Video recording of reproducing steps
Comment 4 Jan Hrcek 2013-06-20 07:23:42 EDT
Created attachment 763431 [details]
Testing CSV file
Comment 5 Ryan Zhang 2013-07-10 02:03:16 EDT
Shoud this reset to ASSIGNED status?
Comment 6 David Gutierrez 2013-07-12 06:32:24 EDT
I'm very very sorry but I can't reproduce it. I watched your video and find no way to run into the problem you describe.

Are you sure your are testing the latest version from github?
Comment 7 Jan Hrcek 2013-07-13 06:30:42 EDT
Yes, just now I tested with the latest version of dashboard-builder - master branch from github. Then I also tried with DR6 build and the problem is present in both.

Now I'm interested in how the application behavior in your case - what happens for you when you click the Cancel button for the first time (as in 00:27 in video)? Does the application go back to list of providers, or what happens in the GUI in your case?


Also please try the following - simplified - steps that isolate the problem better without need for any CSV files:
1) Login and go to Showcase > Administration > Data Providers
2) Click "Edit data provider properties" (2nd button) for "Expense reports demo"
3) Now click Cancel (What happens in your case? For me it just refreshes page, but the Data providers panel stays in the state "Editing data provider Expense reports demo properties" - I think it should go back to the list of data providers - but to do that I have to click Cancel for the second time)

The same thing is happening when editting properties of SQL properties.
Please let me know what does the applicatio do in these 2 cases when you try it.
Comment 8 David Gutierrez 2013-07-13 07:09:00 EDT
Unfortunately (or not ;-)), it works fine for me in both cases.

May be we're facing a browser/OS issue, I don't know. I've been reviewing the HTML code of data provider properties page and seen there might be a little issue with the HTML format which could cause a potential failure in some browsers.

I've just pushed a fix and I really think it's worth to give it a try.
https://github.com/droolsjbpm/dashboard-builder/commit/94109566ebcdb6f4b40a9963a84ea1fcb8d947b6

If still failing please indicate the following:

* Operating system: ?

* Browser: ?

* Database: ?
Comment 9 Jan Hrcek 2013-07-13 07:46:56 EDT
Hooray, I just tested with your latest commit and now it works :-) Now when cancel is pressed it goes correctly back to the list of data providers. I'll verify this BZ later, when the commit is included in the productized build.
Comment 11 Jan Hrcek 2013-09-04 03:40:36 EDT
Verified with BPMS 6.0.0.ER2

Note You need to log in before you can comment on or make changes to this bug.