Bug 967457 - specify command line parameters for dhcpd is impossible with systemd unit
specify command line parameters for dhcpd is impossible with systemd unit
Status: CLOSED DUPLICATE of bug 909733
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
18
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 04:19 EDT by Frantisek Hanzlik
Modified: 2013-05-28 02:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 02:43:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Hanzlik 2013-05-27 04:19:58 EDT
Description of problem:
Now isn't possible to specify command line arguments (as e.g. listening interfaces, config file, etc.) - that what was defined in /etc/sysconfig/dhcpd in OPTIONS variable in old gold pre-systemd times.
Some of command line parameters are fixed in dhcpd unit, but it is senseless
edit this unit for each individual setting, moreover this is incompatible with previous behavior.

Version-Release number of selected component (if applicable):
dhcp-4.2.5-7.fc18.i686

Expected results:
IMO for backward compatibility /etc/sysconfig/dhcpd options should be possible.
Comment 1 Tomáš Hozza 2013-05-28 02:43:15 EDT
We dropped using EnvironmentFile in dhcpd.service file in Fedora 18. If you need
to use custom dhcpd.service file you should copy the whole service file from
/lib/systemd/system to /etc/systemd/system and edit it there. Service files in
/etc/systemd/system have higher precedence over service files in
/lib/systemd/system.

For more information please see:
http://fedoraproject.org/wiki/Systemd#How_do_I_customize_a_unit_file.2F_add_a_custom_unit_file.3F

*** This bug has been marked as a duplicate of bug 909733 ***

Note You need to log in before you can comment on or make changes to this bug.