Bug 967458 - Cannot send files over mate-bluetooth-sendto
Cannot send files over mate-bluetooth-sendto
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mate-bluetooth (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 04:21 EDT by Álvaro Castillo
Modified: 2013-10-25 20:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 20:56:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error description. (43.84 KB, image/png)
2013-05-27 04:21 EDT, Álvaro Castillo
no flags Details

  None (edit)
Description Álvaro Castillo 2013-05-27 04:21:03 EDT
Created attachment 753516 [details]
Error description.

Description of problem:

Cannot send files over mate-bluetooth-sendto

Devices such as smartphones can be "linked", but cannot send files over bluetooth.

Version-Release number of selected component (if applicable):

mate-bluetooth-libs-1.6.0-1.fc19.x86_64
mate-bluetooth-1.6.0-1.fc19.x86_64

Steps to Reproduce:
1. Enable Bluetooth on your device, do visible.
2. Run mate-bluetooth-sendto and select your file want to share.

Additional info:

I added an screenshot about an error of display on "Transfer window".
Comment 1 Wolfgang Ulbrich 2013-05-27 04:55:17 EDT
Is gvfs-obexftp and bluez installed on your system?
Comment 2 Álvaro Castillo 2013-05-27 07:37:07 EDT
Yes.

$ rpm -qa |grep obex*
obexftp-libs-0.23-13.fc19.x86_64
obex-data-server-0.4.6-5.fc19.x86_64
os-prober-1.58-1.fc19.x86_64
gvfs-obexftp-1.16.2-2.fc19.x86_64
openobex-1.5-8.fc19.x86_64
adobe-release-x86_64-1.0-1.noarch
obexfs-0.12-6.fc19.x86_64

$ rpm -qa |grep bluez*
bluez-4.101-6.fc19.x86_64
bluez-gstreamer-4.101-6.fc19.x86_64
mate-bluetooth-libs-1.6.0-1.fc19.x86_64
bluez-libs-4.101-6.fc19.x86_64
bluebird-gtk3-theme-0.6.2-1.fc19.noarch
blueman-1.23-6.fc19.x86_64
gnome-bluetooth-libs-3.8.0-1.fc19.x86_64
bluez-cups-4.101-6.fc19.x86_64
mate-bluetooth-1.6.0-1.fc19.x86_64
Comment 3 Wolfgang Ulbrich 2013-05-27 11:49:40 EDT
(In reply to Álvaro Castillo from comment #2)
> Yes.
> 
> $ rpm -qa |grep obex*
> obexftp-libs-0.23-13.fc19.x86_64
> obex-data-server-0.4.6-5.fc19.x86_64
> os-prober-1.58-1.fc19.x86_64
> gvfs-obexftp-1.16.2-2.fc19.x86_64
> openobex-1.5-8.fc19.x86_64
> adobe-release-x86_64-1.0-1.noarch
> obexfs-0.12-6.fc19.x86_64
> 
> $ rpm -qa |grep bluez*
> bluez-4.101-6.fc19.x86_64
> bluez-gstreamer-4.101-6.fc19.x86_64
> mate-bluetooth-libs-1.6.0-1.fc19.x86_64
> bluez-libs-4.101-6.fc19.x86_64
> bluebird-gtk3-theme-0.6.2-1.fc19.noarch
> blueman-1.23-6.fc19.x86_64
> gnome-bluetooth-libs-3.8.0-1.fc19.x86_64
> bluez-cups-4.101-6.fc19.x86_64
> mate-bluetooth-1.6.0-1.fc19.x86_64

I see no obexd package in your list.
Because this package provide the missing dbus sevice file from your immage.
/usr/share/dbus-1/services/obex-client.service
Comment 4 Wolfgang Ulbrich 2013-05-27 11:52:03 EDT
sorry misspell.
Because this package provide the missing dbus service file from your image.
/usr/share/dbus-1/services/obex-client.service
Comment 5 Álvaro Castillo 2013-05-28 17:59:44 EDT
I have installed obexd, but I cannot send files yet.

Now, windows shows this output message:

"Unable to find service record"

What's happen?
Comment 6 Álvaro Castillo 2013-06-07 19:58:20 EDT
When I try to get files over Bluetooth that's failed too.

I installed mate-user-share required by http://wiki.mate-desktop.org/docs:mate-bluetooth#receive_files but does not work.

Note: Please include mate-user-share into MATE Spin and group (YUM).
Comment 7 Wolfgang Ulbrich 2013-06-08 01:45:21 EDT
My prob is that i haven't a bluetooth device for testing.
Can you test something?
Copy this file http://raveit65.fedorapeople.org/div/61-mate-bluetooth-rfkill.rules
to /lib/udev/rules.d/ and restart the system?
This is taken from gnome-bluetooth.
Comment 8 Wolfgang Ulbrich 2013-06-10 16:49:39 EDT
Can you test this build to see if it fix your issue?
http://koji.fedoraproject.org/koji/taskinfo?taskID=5488972
Comment 9 Álvaro Castillo 2013-06-11 18:45:00 EDT
Wolfgang, these build works fine sending files from PC into smartphone, but that fail to send files from smartphone into PC.
Comment 10 Wolfgang Ulbrich 2013-06-13 05:33:57 EDT
Thanks Álvaro, we are on the right way.
I open a report at upstream for this.
https://github.com/mate-desktop/mate-bluetooth/issues/11

Is selinux enable on your system?
Can you test if disabling selinux helps?

As a workaround for you until mate-bluetooth is fixed, can you try out if blueman or gnome-bluetooth are working in your mate-session.
For gnome-bluetooth you need to edit /etc/xdg/autostart/bluetooth-applet.desktop,
change this line

OnlyShowIn=GNOME;XFCE;LXDE;
to
OnlyShowIn=GNOME;XFCE;LXDE;MATE;

and restart the session, now you should see the gnome-bluetooth applet in systray.
Comment 11 Wolfgang Ulbrich 2013-06-13 05:36:20 EDT
i forgot, disable mate-bluetooth applet in autostart for the test case using blueman or gnome-bluetooth.
Comment 12 Fedora Update System 2013-07-07 07:37:58 EDT
mate-bluetooth-1.6.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-bluetooth-1.6.0-2.fc19
Comment 13 Fedora Update System 2013-07-15 21:49:50 EDT
mate-bluetooth-1.6.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-07-16 15:40:28 EDT
mate-bluetooth-1.6.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-bluetooth-1.6.0-3.fc18
Comment 15 Fedora Update System 2013-07-16 15:40:41 EDT
mate-bluetooth-1.6.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-bluetooth-1.6.0-3.fc19
Comment 16 Fedora Update System 2013-07-16 15:40:53 EDT
mate-bluetooth-1.6.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mate-bluetooth-1.6.0-3.fc17
Comment 17 Fedora Update System 2013-07-18 00:00:05 EDT
mate-bluetooth-1.6.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-07-18 01:48:50 EDT
mate-bluetooth-1.6.0-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-07-18 01:51:30 EDT
mate-bluetooth-1.6.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-07-18 01:53:34 EDT
mate-bluetooth-1.6.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Christoph Wickert 2013-07-28 15:32:25 EDT
You need to enable "Receive files over Bluetooth" in mate-file-share-properties (which is part of the mate-user-share package).
Comment 22 Wolfgang Ulbrich 2013-07-28 16:47:24 EDT
Christoph,
thanks for your hint, but this issue is confirmed by upstream.
Comment 23 Christoph Wickert 2013-07-28 17:12:01 EDT
So what exactly is/was the issue? Is there an upstream bug report you can add as reference?
Comment 24 Wolfgang Ulbrich 2013-07-28 17:25:14 EDT
https://github.com/mate-desktop/mate-bluetooth/issues/11
Sending files only works in on direction, destop to smartphone but not from smartphone to desktop.(In reply to Álvaro Castillo from comment #9)
> Wolfgang, these build works fine sending files from PC into smartphone, but
> that fail to send files from smartphone into PC.
Comment 25 Christoph Wickert 2013-07-29 04:10:02 EDT
I don't see any activity in that bug. What about the confirmation from upstream? Does upstream have a clue what's wrong or at least some instructions for us to debug the problem?
Comment 26 Wolfgang Ulbrich 2013-07-29 04:45:20 EDT
I'm part of upstream, and we have test it on other distros too.
Is this enough information for you?
And sorry i don't use mate-bluetooth and i don't have a device for testing.
Comment 27 Christoph Wickert 2013-07-29 05:28:53 EDT
I do have devices to test, but I don't have information what to test.

Please do not close this bug unless it is really fixed.
Comment 28 Wolfgang Ulbrich 2013-07-29 06:50:44 EDT
(In reply to Christoph Wickert from comment #27)
> I do have devices to test, but I don't have information what to test.
> 
> Please do not close this bug unless it is really fixed.

Try send a file from your device to you notebook/PC.
As you can see i didn't close the bug with latest update which has fixed 'sending files from PC/notebook to smartphone'.
Comment 29 Christoph Wickert 2013-08-01 10:59:50 EDT
Yeah, but MODIFIED is wrong nevertheless, as it means: "This bug has had a fix generated and tested by the component owner, and the code has been checked into CVS." This is not the case.
Comment 30 Dan Mashal 2013-08-01 19:58:00 EDT
so anyways, is this fixed?
Comment 31 Wolfgang Ulbrich 2013-10-25 20:56:52 EDT
For f20 we're switching to bluedevil because of missing bluez5 support of mate-bluetooth.
So this issue will never be fix in f19.

Note You need to log in before you can comment on or make changes to this bug.