Bug 967471 - html5lib updates
html5lib updates
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-html5lib (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Praveen Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 04:48 EDT by Terje Røsten
Modified: 2013-07-20 05:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-html5lib-1.0b2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 23:13:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
html5lib spec file patch (2.18 KB, patch)
2013-06-29 08:34 EDT, Terje Røsten
no flags Details | Diff

  None (edit)
Description Terje Røsten 2013-05-27 04:48:40 EDT
Description of problem:

Please consider to update python-html5lib to 1.0b2.

Project has moved here: https://github.com/html5lib/html5lib-python

Support for Python3 has been improved.
Comment 1 Praveen Kumar 2013-05-27 12:15:43 EDT
Will work on it this weekend and update on repo.
Comment 2 Praveen Kumar 2013-06-02 22:26:06 EDT
nosetests is failing for latest source, updated to upstream. Will update it when source get updated for nosetests.
Comment 3 Terje Røsten 2013-06-29 08:32:56 EDT
I created a updated package, no test errors.

spec: http://terjeros.fedorapeople.org/python-html5lib/python-html5lib.spec
srpm: http://terjeros.fedorapeople.org/python-html5lib/python-html5lib-1.0-0.b2.1.fc18.src.rpm

Diff attached. Please apply.
Comment 4 Terje Røsten 2013-06-29 08:34:30 EDT
Created attachment 766888 [details]
html5lib spec file patch

Patch to html5lib spec to update to 1.0b2.
Comment 5 Praveen Kumar 2013-07-01 21:30:06 EDT
I cloned latest source from github and for that nosetests failing.I think it's good to use latest source, I am still waiting for James reply on it.
Comment 6 Terje Røsten 2013-07-02 02:46:26 EDT
Ok, please note that you have to remove these lines in setup section,
if not some Python 3 tests will fail:

find %{py3dir} -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python3}|'
2to3 --write --nobackups %{py3dir}

No conversion is needed. 
python-html5lib support Python 2.6+ and 3.2+ out of the box now.
Comment 7 Fedora Update System 2013-07-07 23:16:31 EDT
python-html5lib-1.0b2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-html5lib-1.0b2-1.fc19
Comment 8 Fedora Update System 2013-07-07 23:27:22 EDT
python-html5lib-1.0b2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-html5lib-1.0b2-1.fc18
Comment 9 Terje Røsten 2013-07-08 02:04:41 EDT
Thanks!
Comment 10 Praveen Kumar 2013-07-08 02:13:50 EDT
Hi Sten,

Please verify latest packages and provide your karma for it. Thanks !!
Comment 11 Terje Røsten 2013-07-08 09:31:58 EDT
Why have you remove Python 3 support?

Your changelog is a bit short:

 http://pkgs.fedoraproject.org/cgit/python-html5lib.git/log/
Comment 12 Praveen Kumar 2013-07-08 09:37:22 EDT
python 3 support is there, I didn't remove anything.
I made clog sort.
http://pkgs.fedoraproject.org/cgit/python-html5lib.git/commit/?id=f2f07e6cf55f6c83b55d2a2ee36f604521880311
Comment 13 Terje Røsten 2013-07-08 10:25:23 EDT
http://pkgs.fedoraproject.org/cgit/python-html5lib.git/diff/python-html5lib.spec?id=f2f07e6cf55f6c83b55d2a2ee36f604521880311

diff --git a/python-html5lib.spec b/python-html5lib.spec
index ea2edcf..40ce9a2 100644
--- a/python-html5lib.spec
+++ b/python-html5lib.spec
@@ -1,23 +1,25 @@
-%global modulename html5lib
-%global with_python3 1
+%global modulename html5lib

And no Python 3 package here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=432053
Comment 14 Fedora Update System 2013-07-08 13:00:47 EDT
python-html5lib-1.0b2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-html5lib-1.0b2-2.fc18
Comment 15 Fedora Update System 2013-07-08 13:24:53 EDT
python-html5lib-1.0b2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-html5lib-1.0b2-2.fc19
Comment 16 Terje Røsten 2013-07-08 15:39:24 EDT
Thanks for Python 3 fix. 

Version and release also seems to need work, the reason is that
1.0b2 will be newer (as been by rom/yum) than 1.0, which will cause trouble when 1.0 is released (it will not be a update in rpm/yum speak).

Please see here for full details:

https://fedoraproject.org/wiki/Packaging:NamingGuidelines?rd=Packaging/NamingGuidelines#NonNumericRelease
Comment 17 Fedora Update System 2013-07-08 21:37:06 EDT
Package python-html5lib-1.0b2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-html5lib-1.0b2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12614/python-html5lib-1.0b2-1.fc19
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-07-16 23:13:51 EDT
python-html5lib-1.0b2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-07-16 23:14:59 EDT
python-html5lib-1.0b2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-07-20 05:41:39 EDT
python-html5lib-1.0b2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2013-07-20 05:53:34 EDT
python-html5lib-1.0b2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.