Bug 967472 - Support for partial repositories for kickstart
Support for partial repositories for kickstart
Status: CLOSED DUPLICATE of bug 967531
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 04:49 EDT by Vojtěch Boček
Modified: 2013-05-27 07:20 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 07:20:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
packaging.log (20.21 KB, text/plain)
2013-05-27 04:49 EDT, Vojtěch Boček
no flags Details
Kickstart file I used. (680 bytes, text/plain)
2013-05-27 04:50 EDT, Vojtěch Boček
no flags Details

  None (edit)
Description Vojtěch Boček 2013-05-27 04:49:40 EDT
Created attachment 753525 [details]
packaging.log

Description of problem:
I use following command to install new VM from partial repository:
sudo virt-install --name test --ram 1536 --disk pool=default,size=10 --location http://download.eng.brq.redhat.com/pub/fedora/fedora-alt/stage/19-Beta-RC4/Fedora/x86_64/os/ --initrd-inject gnome.ks --extra-args "ks=file://gnome.ks"

Without the kickstart file, all works well:

INFO packaging: configuring base repo
DEBUG packaging: adding yum repo anaconda with baseurl http://download.eng.brq.redhat.com/pub/fedora/fedora-alt/stage/19-Beta-RC4/Fedora/x86_64/os/ and mirrorlist None
ERR packaging: base repo (url/http://download.eng.brq.redhat.com/pub/fedora/fedora-alt/stage/19-Beta-RC4/Fedora/x86_64/os/) not valid -- removing it
INFO packaging: using default repos from local yum configuration
INFO packaging: gathering repo metadata
DEBUG packaging: getting repo metadata for fedora
DEBUG packaging: getting repo metadata for updates-testing
DEBUG packaging: getting repo metadata for updates

But when I use kickstart file with no install method nor repo command specified, anaconda won't fall back to default repositories. I tried to add "repo --name=fedora" to .ks file, but the result is still the same.

INFO packaging: updating base repo
INFO packaging: configuring base repo
DEBUG packaging: adding yum repo anaconda with baseurl http://download.eng.brq.redhat.com/pub/fedora/fedora-alt/stage/19-Beta-RC4/Fedora/x86_64/os/ and mirrorlist None
ERR packaging: base repo (url/http://download.eng.brq.redhat.com/pub/fedora/fedora-alt/stage/19-Beta-RC4/Fedora/x86_64/os/) not valid -- removing it
DEBUG packaging: disabling repo fedora
DEBUG packaging: disabling repo updates-testing
DEBUG packaging: disabling repo updates
INFO packaging: gathering repo metadata

I think I found the part where anaconda disables the repositories[1], and it seems like this is intended behavior, but Anaconda's wiki[2] says that repos from /etc/anaconda.repos.d should be used by default.

[1]: https://git.fedorahosted.org/cgit/anaconda.git/tree/pyanaconda/packaging/yumpayload.py?id=33db7ad5a7c86d743fe4893a46ac5d91ce83cae5#n471
[2]: http://fedoraproject.org/wiki/Anaconda/Kickstart#repo


Version-Release number of selected component (if applicable):
Anaconda 19.30-1


How reproducible:
100%


Steps to Reproduce:
1. Prepare kickstart file, don't specify install method or repo
2. Launch installation using partial repository in inst.repo argument and use the kickstart

Actual results:
Anaconda disables default repositories because the repository in inst.repo is not complete.

Expected results:
Anaconda should fall back to default "Closest mirror", just like it does in non-automated mode.
Comment 1 Vojtěch Boček 2013-05-27 04:50:37 EDT
Created attachment 753526 [details]
Kickstart file I used.
Comment 2 Vojtěch Boček 2013-05-27 07:20:49 EDT

*** This bug has been marked as a duplicate of bug 967531 ***

Note You need to log in before you can comment on or make changes to this bug.