Bug 967520 - Alert condition of type Availability Change does not allow to set all possible values
Alert condition of type Availability Change does not allow to set all possibl...
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Monitoring - Alerts, UI (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jirka Kremser
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 06:44 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 13:01:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-05-27 06:44:53 EDT
Description of problem:

When I am creating new alert condition of "Availability Change" type, I am able to select only 3 options:

Goes down, Goes not up, Goes up

but, AlertConditionOperator defines more values.

    AVAIL_GOES_DOWN(Type.STATELESS), // avail becomes DOWN from anything else
    AVAIL_GOES_DISABLED(Type.STATELESS), // avail becomes DISABLED from anything else
    AVAIL_GOES_UNKNOWN(Type.STATELESS), // avail becomes UNKNOWN from anything else
    AVAIL_GOES_NOT_UP(Type.STATELESS), // convenience for avail becomes DOWN | DISABLED | UNKNOWN from UP    
    AVAIL_GOES_UP(Type.STATELESS), //  avail becomes UP from anything else


UI should list all possible values, not just those 3. (It is possible to create alert condition with AVAIL_GOES_UNKNOWN using REST API, editing such condition in UI is a little ackward) 

Version-Release number of selected component (if applicable):
JON 3.2.Alpha
Comment 1 Jirka Kremser 2013-05-28 13:01:44 EDT
The states AVAIL_GOES_UNKNOWN and AVAIL_GOES_DISABLED are not allowed for a resource of type platform. For other resource types it is possible to set these values. If REST API allows this type of alert condition, then it is probably a bug. 
We should probably add the check to the SLSB, because if it is exposed via CLI it needs to be checked as well.

Note You need to log in before you can comment on or make changes to this bug.