Bug 967538 - Gluster: Inconsistency while searching for VOLUME using search tab in engine UI
Gluster: Inconsistency while searching for VOLUME using search tab in engine UI
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Sankarshan Mukhopadhyay
SATHEESARAN
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 07:49 EDT by SATHEESARAN
Modified: 2016-08-17 10:38 EDT (History)
9 users (show)

See Also:
Fixed In Version: 3.6.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
virt rhev integration
Last Closed: 2016-08-17 10:38:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack+
rule-engine: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)
Searching for cluster properties, NOTE the semi-colon is placed immediately after keyword "cluster" (122.95 KB, image/png)
2013-05-27 07:55 EDT, SATHEESARAN
no flags Details
Searching for volumes properties, NOTE the semi-colon is placed immediately after keyword "volumes" (115.46 KB, image/png)
2013-05-27 07:56 EDT, SATHEESARAN
no flags Details
Searching for volumes properties, NOTE the semi-colon is placed after a space after keyword "volumes" (127.34 KB, image/png)
2013-05-27 07:58 EDT, SATHEESARAN
no flags Details
volume-properties screenshot (59.48 KB, image/png)
2016-04-12 10:00 EDT, Sahina Bose
no flags Details

  None (edit)
Description SATHEESARAN 2013-05-27 07:49:36 EDT
Description of problem:

While searching out for volume using, 'search tab', in RHEVM UI, it requires a space before colon for autocompletion of volume properties, while this is not the case for rest of the components, like cluster, template, vm, etc

(i.e) Typing "vm:" / "cluster:" / "template:", etc gives properties of that component, while when typed as, "volumes:" I am not seeing any relevant options,
and typing "volumes :", lists the available options

Version-Release number of selected component (if applicable):
RHEVM : 3.1.4 [ 3.1.0-53.el6ev ]


How reproducible:


Steps to Reproduce:
1. Try searching in search tab in RHEVM UI,for volumes. and wait for autocompletion for the properties of the volume

(i.e) "volumes: "


Actual results:
There is no autocompletion for Volumes alone, but if I give a space following,
(i.e) "volumes :", I could see volumes properties coming up

Expected results:
The volume properties should be auto-completed when typed, "volume:" in search tab

Additional info:
Attached the screenshots while searching
Comment 1 SATHEESARAN 2013-05-27 07:55:43 EDT
Created attachment 753596 [details]
Searching for cluster properties, NOTE the semi-colon is placed immediately after  keyword "cluster"
Comment 2 SATHEESARAN 2013-05-27 07:56:55 EDT
Created attachment 753597 [details]
Searching for volumes properties, NOTE the semi-colon is placed immediately after  keyword "volumes"
Comment 3 SATHEESARAN 2013-05-27 07:58:52 EDT
Created attachment 753598 [details]
Searching for volumes properties, NOTE the semi-colon is placed after a space after keyword "volumes"
Comment 6 Eyal Edri 2015-02-25 03:40:26 EST
3.5.1 is already full with bugs (over 80), and since none of these bugs were added as urgent for 3.5.1 release in the tracker bug, moving to 3.5.2
Comment 7 Sandro Bonazzola 2015-10-26 08:46:58 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 8 Red Hat Bugzilla Rules Engine 2015-11-30 15:42:43 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 9 Sahina Bose 2016-04-12 10:00 EDT
Created attachment 1146465 [details]
volume-properties screenshot

With RHEV-M 3.6.3 - I see the volumes properties autocompleted as per screenshot, without needing a space after typing "Volumes".
Comment 10 Sahina Bose 2016-04-12 10:01:06 EDT
Moving to ON_QA to be verified
Comment 12 SATHEESARAN 2016-08-16 06:36:05 EDT
Tested with RHGS 3.1.3 ( with vdsm 4.17.33-1 ) added to 3.6 cluster in RHV 4.0.2-6

When searched with "volume:type = distribute", the required volumes are listed exactly

Note You need to log in before you can comment on or make changes to this bug.