Bug 967549 - Seam2.3 projects generated by seam-gen contains doubled jboss-deployment-structure xml
Seam2.3 projects generated by seam-gen contains doubled jboss-deployment-stru...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.2.0
Unspecified Unspecified
unspecified Severity medium
: CR1
: 2.3.0
Assigned To: Marek Novotny
Tomas Remes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 08:22 EDT by Tomas Remes
Modified: 2013-07-16 07:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Seam-gen generated applications of type EAR had duplicated jboss-deployment-structure.xml file in <EAR>/META-INF/ and <WAR>/WEB-INF directories. This has been fixed by removing the duplication from EAR type projects.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:34:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Remes 2013-05-27 08:22:12 EDT
Generate some project by seam-gen and notice that jboss-deployment-structure.xml descriptor is present in META-INF and WEB-INF folders. This happens for both - WAR and EAR projects. 
This is newly validated in JBDS 7.0.0.Beta1, therefore it produces errors in JBDS.
Comment 1 Tomas Remes 2013-05-27 08:31:50 EDT
To be clear - it looks like that the reason of the error is other problem. Anyway I think there should be only one jboss-deployment-structure descriptor.
Comment 2 Marek Novotny 2013-05-30 07:04:41 EDT
Tomas, could you create an upstream jira issue for this?
Comment 3 Marek Novotny 2013-06-04 14:19:12 EDT
added exclusion for war target in EAR type project. 

Fixed by https://source.jboss.org/changelog/Seam?cs=15547
Comment 5 Tomas Remes 2013-06-11 06:59:52 EDT
This fix is not correct. I can still see this file in META-INF and WEB-INF in WAR project as well as in EAR project. 
I think this should be fixed in jboss-seam-gen/build.xml file (just add exclusion into  file-copy target) instead of jboss-seam-gen/build-scripts/build.xml file.
Comment 6 Tomas Remes 2013-06-11 09:24:54 EDT
I meant these files in generated project, where this could be little bit misleading, and not the files in created deployment.  Sorry for confusion. 
In the deployment is it ok.
Comment 7 Marek Novotny 2013-06-11 10:06:10 EDT
fixed by https://source.jboss.org/changelog/Seam?cs=15557
Comment 9 Tomas Remes 2013-06-26 03:50:40 EDT
Verified in 2.3.0.CR1 release.
Comment 10 Sneha 2013-07-03 05:52:18 EDT
Updated doc text.

Note: This bug was not a known issue in wfk 2.2 RN.

Note You need to log in before you can comment on or make changes to this bug.