Bug 967581 - Broken dependency on npm(qs)
Broken dependency on npm(qs)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nodejs-request (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jamie Nguyen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 09:49 EDT by Daniel Narvaez
Modified: 2013-06-16 14:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: nodejs-request-2.16.6-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 22:24:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Narvaez 2013-05-27 09:49:15 EDT
[buildbot@bs-schroedinger-x86-64 ~]$ sudo yum update              
Resolving Dependencies
--> Running transaction check
---> Package nodejs-qs.noarch 0:0.5.6-1.fc19 will be updated
--> Processing Dependency: npm(qs) < 0.6 for package: nodejs-request-2.16.6-2.fc19.noarch
---> Package nodejs-qs.noarch 0:0.6.5-1.fc19 will be an update
--> Finished Dependency Resolution
Error: Package: nodejs-request-2.16.6-2.fc19.noarch (@fedora)
           Requires: npm(qs) < 0.6
           Removing: nodejs-qs-0.5.6-1.fc19.noarch (@fedora)
               npm(qs) = 0.5.6
           Updated By: nodejs-qs-0.6.5-1.fc19.noarch (updates-testing)
               npm(qs) = 0.6.5
 You could try using --skip-broken to work around the problem
Comment 1 Jamie Nguyen 2013-05-28 03:03:48 EDT
Sorry, my mistake (due to different version of nodejs-request between f18 and f19). Update to follow.
Comment 2 Fedora Update System 2013-05-28 03:05:15 EDT
nodejs-request-2.16.6-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nodejs-request-2.16.6-4.fc19
Comment 3 Fedora Update System 2013-05-28 03:14:10 EDT
nodejs-request-2.16.6-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nodejs-request-2.16.6-4.el6
Comment 4 Fedora Update System 2013-05-28 12:16:55 EDT
Package nodejs-request-2.16.6-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nodejs-request-2.16.6-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9469/nodejs-request-2.16.6-4.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-05 22:24:35 EDT
nodejs-request-2.16.6-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-06-16 14:32:25 EDT
nodejs-request-2.16.6-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.