Bug 967627 - fdisk segfault while deleting last remaining partition
fdisk segfault while deleting last remaining partition
Status: CLOSED DUPLICATE of bug 961894
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
19
i386 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 12:41 EDT by Petr Janda
Modified: 2013-05-27 14:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 14:05:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console output (904 bytes, text/plain)
2013-05-27 12:41 EDT, Petr Janda
no flags Details

  None (edit)
Description Petr Janda 2013-05-27 12:41:26 EDT
Created attachment 753654 [details]
Console output

Description of problem:



Version-Release number of selected component (if applicable):
util-linux 2.23

How reproducible:
always 

Steps to Reproduce:
1. fdisk /dev/sda
2. delete all partitions except one - does not matter where is located on hdd
3. type "d" and press enter

Actual results:
fdisk segfaults

Expected results:
fdisk deletes last partition

Additional info:
only on i386 - on x86_64 everything works OK
fdisk in dracut on installation DVD is affected too
Comment 1 Petr Janda 2013-05-27 14:05:11 EDT
Different symptoms, but patch from
https://bugzilla.redhat.com/show_bug.cgi?id=961894
solve this issue too.

*** This bug has been marked as a duplicate of bug 961894 ***

Note You need to log in before you can comment on or make changes to this bug.