Bug 967640 - ru_RU.dic contains both CRLF *and* LF line terminators
ru_RU.dic contains both CRLF *and* LF line terminators
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hunspell-ru (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 14:07 EDT by Mike FABIAN
Modified: 2013-05-29 10:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 08:14:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike FABIAN 2013-05-27 14:07:10 EDT
[mfabian@Fedora-19-Beta-RC4-x86_64-netins myspell]$ file ru_RU.dic 
ru_RU.dic: ISO-8859 text, with CRLF, LF line terminators
[mfabian@Fedora-19-Beta-RC4-x86_64-netins myspell]$
Comment 1 Caolan McNamara 2013-05-28 05:48:49 EDT
Well, hunspell doesn't care whether a line ends in CRLF or LF it handles both equivalently and we presumably have a bunch of mixed line endings in a pile of dictionaries so is there any pressing reason to change them ?
Comment 2 Mike FABIAN 2013-05-29 01:13:58 EDT
I stumbled over this when working on ibus-typing-booster, but I
added a workaround for ibus-typing-booster already to handle both
line endings. So it is not urgent to change this, but it is not nice
to have this mixed line endings.
Comment 3 Caolan McNamara 2013-05-29 08:14:52 EDT
I'm inclined to mark this as wontfix/notabug and force "just sucking it down" that the dicts are allowed to have variable line terminators because seeing as hunspell accept that then the dicts are "just like that" in the wild and cleaning them up locally in fedora doesn't help the global story.
Comment 4 Mike FABIAN 2013-05-29 10:48:42 EDT
Yes, of course, it would be good to get in contact with upstream to
resolve that upstream though.

Note You need to log in before you can comment on or make changes to this bug.