Bug 967641 - keepalived vrrp alert emails are missing to-header
keepalived vrrp alert emails are missing to-header
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: keepalived (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ryan O'Hara
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 14:09 EDT by Pasi Karkkainen
Modified: 2014-10-14 03:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: keepalived-1.2.13-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:12:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
keepalived-1.2.7-add-smtp-email-to-header.patch (3.26 KB, patch)
2013-05-27 14:09 EDT, Pasi Karkkainen
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1510 normal SHIPPED_LIVE keepalived bug fix and enhancement update 2014-10-13 21:22:28 EDT

  None (edit)
Description Pasi Karkkainen 2013-05-27 14:09:34 EDT
Created attachment 753659 [details]
keepalived-1.2.7-add-smtp-email-to-header.patch

Description of problem:

keepalived vrrp alert emails are missing to-header, so the "To" field is empty in email programs, which makes filtering/sorting email harder. 

I've written a patch to implement the missing to-header, see:

Email post to keepalived-devel mailinglist:
http://sourceforge.net/mailarchive/message.php?msg_id=29897449

patch (also added to this bz as an attachment):
http://sourceforge.net/mailarchive/attachment.php?list_name=keepalived-devel&message_id=20120928122744.GR8912%40reaktio.net&counter=1

It'd be nice to get that patch included in rhel6 keepalived rpm!


Version-Release number of selected component (if applicable):
keepalived-1.2.7-3
Comment 1 Ryan O'Hara 2013-08-18 11:53:36 EDT
Is there an upstream pull request for this patch? I didn't see one. I think this patch will need to be rebased for it to apply to master branch.
Comment 2 Pasi Karkkainen 2013-08-19 04:36:16 EDT
Patch submission to keepalived-devel:
http://marc.info/?l=keepalived-devel&m=134883532417448&w=2

"I will merge your patch in next release":
http://marc.info/?l=keepalived-devel&m=135023180526573&w=2


If it doesn't apply anymore, sure, I can rebase and resend..
Comment 3 Ryan O'Hara 2013-08-19 11:06:44 EDT
(In reply to Pasi Karkkainen from comment #2)
> Patch submission to keepalived-devel:
> http://marc.info/?l=keepalived-devel&m=134883532417448&w=2

Right. I was curious if there was a pull request on github. I don't see one, so what I will do is take your patch and put it in my devel branch on github. I have an outstanding pull request with several patches there already.

> "I will merge your patch in next release":
> http://marc.info/?l=keepalived-devel&m=135023180526573&w=2
> 
> 
> If it doesn't apply anymore, sure, I can rebase and resend..

I see what happened. I think your patch is based on v1.27, which is the latest release, but HEAD of master branch has some cosmetic changes that causes your patch to no apply. I'll fix it to apply to HEAD to make merging upstream easier.
Comment 4 Pasi Karkkainen 2013-08-20 07:52:08 EDT
That's correct, my patch is/was on top of v1.2.7. And yes, feel free to rework the patch and put it to your devel branch and send for upstreaming merging!

Thanks a lot!
Comment 5 Pasi Karkkainen 2013-09-19 18:03:09 EDT
My patch is now included in the recently released upstream keepalived v1.2.8. Thanks!
Comment 9 errata-xmlrpc 2014-10-14 03:12:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1510.html

Note You need to log in before you can comment on or make changes to this bug.