Bug 967650 - SELinux is preventing /usr/lib/xulrunner/plugin-container from 'execmod' accesses on the file /opt/google/talkplugin/libnpgoogletalk.so.
SELinux is preventing /usr/lib/xulrunner/plugin-container from 'execmod' acce...
Status: CLOSED DUPLICATE of bug 955909
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:94efa97152867c574e5077e635b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 15:38 EDT by hrafnkellbrimar
Modified: 2013-05-28 06:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 06:11:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hrafnkellbrimar 2013-05-27 15:38:46 EDT
Description of problem:
Was refreshing Google plus, shortly after installing the google hangout plugin.
SELinux is preventing /usr/lib/xulrunner/plugin-container from 'execmod' accesses on the file /opt/google/talkplugin/libnpgoogletalk.so.

*****  Plugin mozplugger (99.1 confidence) suggests  *************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests  ***************************

If you believe that plugin-container should be allowed execmod access on the libnpgoogletalk.so file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                system_u:object_r:bin_t:s0
Target Objects                /opt/google/talkplugin/libnpgoogletalk.so [ file ]
Source                        plugin-containe
Source Path                   /usr/lib/xulrunner/plugin-container
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xulrunner-21.0-4.fc19.i686
Target RPM Packages           google-talkplugin-3.19.1.0-1.i386
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-300.fc19.i686.PAE #1 SMP Fri
                              May 24 23:19:44 UTC 2013 i686 i686
Alert Count                   4
First Seen                    2013-05-27 19:35:46 GMT
Last Seen                     2013-05-27 19:36:31 GMT
Local ID                      dbf9666f-30fa-4a49-b31b-7f3e79f9db80

Raw Audit Messages
type=AVC msg=audit(1369683391.273:666): avc:  denied  { execmod } for  pid=11903 comm="plugin-containe" path="/opt/google/talkplugin/libnpgoogletalk.so" dev="dm-0" ino=657956 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bin_t:s0 tclass=file


type=SYSCALL msg=audit(1369683391.273:666): arch=i386 syscall=mprotect success=no exit=EACCES a0=b742e000 a1=2e000 a2=5 a3=bf872e40 items=0 ppid=2750 pid=11903 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=plugin-containe exe=/usr/lib/xulrunner/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: plugin-containe,mozilla_plugin_t,bin_t,file,execmod

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-300.fc19.i686.PAE
type:           libreport

Potential duplicate: bug 955909
Comment 1 Miroslav Grepl 2013-05-28 06:11:22 EDT

*** This bug has been marked as a duplicate of bug 955909 ***

Note You need to log in before you can comment on or make changes to this bug.