This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 967671 - addhardware: Don't warn about 'disk in use' if guest's using are RO/shareable
addhardware: Don't warn about 'disk in use' if guest's using are RO/shareable
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 20:17 EDT by Cole Robinson
Modified: 2014-01-14 17:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-14 17:02:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2013-05-27 20:17:42 EDT
One guest is already using an ISO. Try and attach the same ISO to another guest. The addhardware wizard warns that the image is in use by another guest. In this case it should be safe to do, since all users will be readonly. So we shouldn't warn.

Should also check if ISO connect to an existing cdrom device does the same check. And maybe warn if we change readonly/shareable for a device that's already in use.
Comment 1 Cole Robinson 2014-01-14 17:02:04 EST
Fixed upstream now

Note You need to log in before you can comment on or make changes to this bug.