Bug 967677 - RFE - ability to export a book from a CSP map with file-per-chapter instead of file-per-topic
RFE - ability to export a book from a CSP map with file-per-chapter instead o...
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 21:02 EDT by Misty Stanley-Jones
Modified: 2014-06-18 03:05 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.33.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-30 21:12:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misty Stanley-Jones 2013-05-27 21:02:09 EDT
In order to sync with upstream GIT repos, it would be nice if we could export with one file per chapter rather than one file per topic. I understand that content could not be easily re-imported using this mechanism (or could it?) so this should probably not be default. Maybe a switch in the CSP map or something in the CSProcessor API.
Comment 1 Lee Newson 2013-05-27 21:06:04 EDT
You can actually do this already by building with the "--server" hidden option.
Comment 2 Misty Stanley-Jones 2013-05-27 22:28:32 EDT
Awesome! Why in the world is it called --server ? And why hidden?
Comment 3 Lee Newson 2013-05-27 23:06:02 EDT
It's called --server because we use it for builds done on a server (ie docbuilder), to save time during the publican build, which is also why it's a hidden parameter. For this RFE though, I'd make it visible and make it something more relevant, maybe "--flatten".

As for the server part it really should be a configuration component anyways and I did have plans to move it there.
Comment 4 Misty Stanley-Jones 2013-05-28 01:53:36 EDT
Why not something like --file-per-chapter? By the way, does this still work if you have an article (one file for the whole article) or a part (one file per chapter, and one file per part with xi:includes to each chapter)?
Comment 5 Lee Newson 2013-05-28 02:08:51 EDT
Parts will work as you mentioned.

I'm fairly sure articles won't work though, but I'd have to verify that. In saying that, that is a bug and should also be fixed though for this RFE.
Comment 6 Lee Newson 2013-06-07 00:51:56 EDT
Added properly in 0.33.0

We've used the "--flatten" parameter, since it really flattens parts, chapters, appendixes and prefaces and so "--flatten" goes better with the existing "--flatten-topics" option (which flattens the topics folder to remove subdirectories). I've also fixed the bug with articles so that now when using "--flatten" the Article will be flattened down to just the one file (excluding standard Publican files).
Comment 7 Lee Newson 2013-06-27 23:11:03 EDT
0.33.0 has now been released.
Comment 8 Misty Stanley-Jones 2013-07-01 22:51:34 EDT
Documented.

Note You need to log in before you can comment on or make changes to this bug.