Bug 967686 - FormatCreateError: ('invalid device specification', '/dev/md/svil-01.zn9.acapulco.ag:root_1')
FormatCreateError: ('invalid device specification', '/dev/md/svil-01.zn9.acap...
Status: CLOSED DUPLICATE of bug 954062
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:f58aa5f990846494cb299e25206...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 23:18 EDT by Gabriel Ramirez
Modified: 2013-05-28 14:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 14:18:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (743.44 KB, text/plain)
2013-05-27 23:19 EDT, Gabriel Ramirez
no flags Details
File: anaconda.log (34.34 KB, text/plain)
2013-05-27 23:19 EDT, Gabriel Ramirez
no flags Details
File: backtrace (1.25 KB, text/plain)
2013-05-27 23:19 EDT, Gabriel Ramirez
no flags Details
File: environ (903 bytes, text/plain)
2013-05-27 23:19 EDT, Gabriel Ramirez
no flags Details
File: ifcfg.log (399 bytes, text/plain)
2013-05-27 23:19 EDT, Gabriel Ramirez
no flags Details
File: lsblk_output (3.76 KB, text/plain)
2013-05-27 23:19 EDT, Gabriel Ramirez
no flags Details
File: nmcli_dev_list (3.46 KB, text/plain)
2013-05-27 23:19 EDT, Gabriel Ramirez
no flags Details
File: packaging.log (335.75 KB, text/plain)
2013-05-27 23:19 EDT, Gabriel Ramirez
no flags Details
File: program.log (48.90 KB, text/plain)
2013-05-27 23:19 EDT, Gabriel Ramirez
no flags Details
File: storage.log (227.85 KB, text/plain)
2013-05-27 23:20 EDT, Gabriel Ramirez
no flags Details
File: syslog (75.50 KB, text/plain)
2013-05-27 23:20 EDT, Gabriel Ramirez
no flags Details
the screen from manual partitioning with the summary of changes (89.50 KB, image/png)
2013-05-27 23:24 EDT, Gabriel Ramirez
no flags Details

  None (edit)
Description Gabriel Ramirez 2013-05-27 23:18:24 EDT
Description of problem:
I tried to install Fedora 19 Beta RC4 x86_64 over existing linux kernel mirror devices

the steps were boot via pxe:

selected the two disk and in the dialog after the done button select custom partitioning

there I saw the md devices so I selected
/dev/md/hostname:boot_1 /boot to format ext4
/dev/md/hostname:root_1 / to format ext4
/dev/md/hostname:swap_1 to format swap
/dev/md/syslinux_0 /var/lib/lh/syslinux

thanks in advance,

gabriel
The following was filed automatically by anaconda:
anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/__init__.py", line 310, in create
    raise FormatCreateError("invalid device specification", self.device)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 779, in create
    DeviceFormat.create(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 471, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 306, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 165, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
FormatCreateError: ('invalid device specification', '/dev/md/svil-01.zn9.acapulco.ag:root_1')

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   ip=dhcp noipv6 method=http://stargate.zn9.acapulco.ag/linux/fedora/19/x86_64 lang=en_US keymap=la-latin1 initrd=../fedora/19/x86_64/isolinux/initrd.img BOOT_IMAGE=../fedora/19/x86_64/isolinux/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 165, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 306, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 471, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 779, in create
    DeviceFormat.create(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/formats/__init__.py", line 310, in create
    raise FormatCreateError("invalid device specification", self.device)
FormatCreateError: ('invalid device specification', '/dev/md/svil-01.zn9.acapulco.ag:root_1')
Comment 1 Gabriel Ramirez 2013-05-27 23:19:03 EDT
Created attachment 753705 [details]
File: anaconda-tb
Comment 2 Gabriel Ramirez 2013-05-27 23:19:09 EDT
Created attachment 753706 [details]
File: anaconda.log
Comment 3 Gabriel Ramirez 2013-05-27 23:19:13 EDT
Created attachment 753707 [details]
File: backtrace
Comment 4 Gabriel Ramirez 2013-05-27 23:19:16 EDT
Created attachment 753708 [details]
File: environ
Comment 5 Gabriel Ramirez 2013-05-27 23:19:20 EDT
Created attachment 753709 [details]
File: ifcfg.log
Comment 6 Gabriel Ramirez 2013-05-27 23:19:23 EDT
Created attachment 753710 [details]
File: lsblk_output
Comment 7 Gabriel Ramirez 2013-05-27 23:19:27 EDT
Created attachment 753711 [details]
File: nmcli_dev_list
Comment 8 Gabriel Ramirez 2013-05-27 23:19:45 EDT
Created attachment 753712 [details]
File: packaging.log
Comment 9 Gabriel Ramirez 2013-05-27 23:19:50 EDT
Created attachment 753713 [details]
File: program.log
Comment 10 Gabriel Ramirez 2013-05-27 23:20:03 EDT
Created attachment 753714 [details]
File: storage.log
Comment 11 Gabriel Ramirez 2013-05-27 23:20:09 EDT
Created attachment 753715 [details]
File: syslog
Comment 12 Gabriel Ramirez 2013-05-27 23:24:58 EDT
Created attachment 753718 [details]
the screen from manual partitioning with the summary of changes
Comment 13 David Lehman 2013-05-28 14:18:29 EDT

*** This bug has been marked as a duplicate of bug 954062 ***

Note You need to log in before you can comment on or make changes to this bug.