Bug 967698 - [virtio-win][netkvm]BSOD(d1) always happen on Job of "NDISTest6.5-[2 Machine]-MPE_Ethernet.xml" failed on HCK for win8-32
[virtio-win][netkvm]BSOD(d1) always happen on Job of "NDISTest6.5-[2 Machine]...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 01:16 EDT by guo jiang
Modified: 2014-01-01 11:36 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 11:36:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump file - win8-32 - MPE (47.73 MB, application/x-zip-compressed)
2013-05-28 01:31 EDT, guo jiang
no flags Details

  None (edit)
Description guo jiang 2013-05-28 01:16:05 EDT
Description of problem:
BSOD with error d1 always happened on Job "NDISTest6.5-[2 Machine]-MPE_Ethernet.xml" failed on HCK for win8-32. 

Version-Release number of selected component (if applicable):
    
   * Red Hat Enterprise Linux Server release 6.4 (Santiago)
   * kernel-2.6.32-369.el6.x86_64    
   * qemu-img-rhev-0.12.1.2-2.359.el6.x86_64
   * virtio-win-prewhql-0.1-61
   * spice-server-0.12.0-12.el6.x86_64
   * seabios-0.6.1.2-27.el6.x86_64
   * vgabios-0.6b-3.7.el6.noarch

How reproducible:
4/4

Steps to Reproduce:
1.Boot guest with CLI:
  test guest:/usr/libexec/qemu-kvm -m 2G -smp 8,cores=8 -cpu cpu64-rhel6,+x2apic,+sep -usb -device usb-tablet -drive file=win8-32-nic2.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:13:33:52:52:21,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:12:53:25:45:12,bus=pci.0,addr=0x6 -uuid d3e76ade-17be-4042-a8d0-2e157bf9106f -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-32-61-nic2,server,nowait -mon chardev=111a,mode=readline -vnc :2 -vga cirrus -name win8-32-nic2-61-HCK -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -monitor stdio
  support guest:/usr/libexec/qemu-kvm -m 6G -smp 8,cores=8 -cpu cpu64-rhel6,+x2apic,+sep -usb -device usb-tablet -drive file=win8-32-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:23:53:12:52:21,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:34:25:13:45:12,bus=pci.0,addr=0x6 -uuid 4673cccf-3027-4ca4-89f3-1ffa0c49e92a -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-32-61-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -vga cirrus -name win8-32-nic1-61-HCK -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -monitor stdio

2.Run job "NDISTest6.5-[2 Machine]-MPE_Ethernet.xml" on HCK.

3.Run task "Run NDISTest Client"

Actual results:
BSOD with error D1 happened.

Expected results:
Job should pass without any error.

Additional info:
This job often BSOD with error 9F (bug 920928), This is the first time BSOD with D1.
Comment 1 guo jiang 2013-05-28 01:18:00 EDT
Windbg info:

---------

5: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: 00000004, memory referenced
Arg2: 00000006, IRQL
Arg3: 00000000, value 0 = read operation, 1 = write operation
Arg4: a257b83f, address which referenced memory

Debugging Details:
------------------


READ_ADDRESS:  00000004 

CURRENT_IRQL:  6

FAULTING_IP: 
netkvm+483f
a257b83f 8b4804          mov     ecx,dword ptr [eax+4]

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

BUGCHECK_STR:  AV

PROCESS_NAME:  svchost.exe

DEVICE_OBJECT: 8aec77a0

DRIVER_OBJECT: 8aec8f30

IMAGE_NAME:  nsiproxy.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  5010ac1e

MODULE_NAME: nsiproxy

FAULTING_MODULE: 90f9b000 nsiproxy

TRAP_FRAME:  dd4c7ad8 -- (.trap 0xffffffffdd4c7ad8)
Unable to read trap frame at dd4c7ad8

EXCEPTION_RECORD:  8e137000 -- (.exr 0xffffffff8e137000)
ExceptionAddress: 816efd51 (nt!KiInterruptMessageDispatch)
   ExceptionCode: 02a00016
  ExceptionFlags: 8e137004
NumberParameters: -2097093093
   Parameter[0]: 00000000
   Parameter[1]: 9ea6f440
   Parameter[2]: 00000000
   Parameter[3]: ffffffff
   Parameter[4]: 9ea6f4ac
   Parameter[5]: 81789400
   Parameter[6]: 00000060
   Parameter[7]: 01000605
   Parameter[8]: 00000005
   Parameter[9]: 00000001
   Parameter[10]: 00000000
   Parameter[11]: 00000001
   Parameter[12]: 00000000
   Parameter[13]: 00000000
   Parameter[14]: ffffffff

LAST_CONTROL_TRANSFER:  from 81788840 to 81711ccc

STACK_TEXT:  
9877b53c 81788840 0000000a 00000004 00000006 nt!KiBugCheck2
9877b53c a257b83f 0000000a 00000004 00000006 nt!KiTrap0E+0x2c8
WARNING: Stack unwind information not available. Following frames may be wrong.
9877b5d8 a257affb a164e1b8 00000010 a164e1b8 netkvm+0x483f
9877b5f0 a2581320 a164e1b8 9877b62f 00000010 netkvm+0x3ffb
9877b608 8300e678 a164e1b8 00000000 9877b62f netkvm+0xa320
9877b66c 816efd63 8e137000 9ea6f440 00000000 ndis!ndisMiniportMessageIsr+0x5d
9877b680 8178946d 8e137000 9ea6f440 dd4c7ad8 nt!KiInterruptMessageDispatch+0x12
9877b680 81bd552e 8e137000 9ea6f440 dd4c7ad8 nt!KiInterruptDispatch+0x6d
9877b71c 81bb7865 82ccf240 0021bb7f 82ccd100 hal!HalpInterruptJumpToVector+0x18e
9877b730 81bb778d 00000001 00000202 00000007 hal!HalpInterruptLowerHardwareIrql+0xaf
9877b748 8164ba0e 00000009 c054d230 00000001 hal!KfLowerIrql+0x23
9877b790 8164a064 00000000 00000001 c054d1e8 nt!KeFlushMultipleRangeTb+0x137
9877b85c 816f636c c054d230 00000009 00000000 nt!MiFlushTbAsNeeded+0x1e7
9877b894 81649280 00000009 00000000 00008be8 nt!MiFlushTbForNonPagedPool+0xcd
9877b8b4 81648747 00000200 00008be4 00000000 nt!MiAllocatePoolPages+0xc0
9877b938 817e0b93 00000000 00000200 00008be4 nt!ExpAllocateBigPool+0xaa
9877b9b4 816526fe 00000200 00008be4 6770534e nt!ExAllocatePoolWithTag+0x963
9877b9fc 90f9c71a 00000208 00008be4 6770534e nt!ExAllocatePoolWithQuotaTag+0x55
9877bac4 90f9d048 0121eedc 0000003c 00000000 nsiproxy!NsippProbeAndAllocateParameters+0x2a8
9877bba0 90f9df5f 9b05c801 8991d3cc 8aec77a0 nsiproxy!NsippEnumerateObjectsAllParameters+0x82
9877bbcc 90f9e05f 00000000 8aec77a0 9a80000e nsiproxy!NsippDispatchDeviceControl+0x81
9877bbe0 81652a7c 8aec77a0 8991d3b0 9a800000 nsiproxy!NsippDispatch+0x33
9877bbfc 81862f1c 8991d444 8991d3b0 9a80db08 nt!IofCallDriver+0x3f
9877bc50 81862991 8aec77a0 00000000 8185fa01 nt!IopSynchronousServiceTail+0x121
9877bcf0 818625c9 8aec77a0 8991d3b0 00000000 nt!IopXxxControlFile+0x3ac
9877bd24 817852fc 00000130 000000b8 00000000 nt!NtDeviceIoControlFile+0x2a
9877bd24 76eb6954 00000130 000000b8 00000000 nt!KiFastCallEntry+0x12c
0121ef3c 00000000 00000000 00000000 00000000 0x76eb6954


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  AV_IMAGE_nsiproxy.sys

BUCKET_ID:  AV_IMAGE_nsiproxy.sys

Followup: MachineOwner
---------
Comment 3 guo jiang 2013-05-28 01:31:30 EDT
Created attachment 753733 [details]
dump file - win8-32 - MPE
Comment 5 guo jiang 2013-06-28 05:29:45 EDT
Verified this issue on virtio-win-prewhql-0.1.65

steps as Description

Actual Result
on build 65: MPE job passed without error report.

Based on the above, this issue has been fixed already!
Comment 6 Mike Cao 2013-06-28 05:31:17 EDT
Based on comment #5 ,Move status to VERIFIED .

Note You need to log in before you can comment on or make changes to this bug.