Bug 967726 - virt-manager: please display the IP address of VMs
virt-manager: please display the IP address of VMs
Status: CLOSED DUPLICATE of bug 1359052
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 03:24 EDT by Florian Weimer
Modified: 2016-08-15 11:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-15 11:52:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2013-05-28 03:24:29 EDT
In the virt-manager main window, please display the IP addresses assigned to running VMs (if any).  This would help those of us who have VMs without proper DNS setup and who cannot remember the IP addresses of VMs (or which change frequently for some reason).

You could also add a context menu item "establish SSH connection to this VM" once you've got the IP address.
Comment 1 Cole Robinson 2013-08-31 12:12:25 EDT
We need a way to get the IP addresses first. There is ongoing upstream libvirt work to pin down an API, once that's done it will be easy for us to add. Duping to the libvirt bug

*** This bug has been marked as a duplicate of bug 559366 ***
Comment 2 Florian Weimer 2016-08-15 11:46:54 EDT
libvirt support for IP addresses is in Fedora 24 (and visible via domifaddr in virsh), but it is still not shown in the virt-manager UI (at least not in the top-level overview pane, where it would make most sense).
Comment 3 Cole Robinson 2016-08-15 11:52:22 EDT
Duping to the upstream virt-manager bug tracking this, i'll try to get it in the next release

*** This bug has been marked as a duplicate of bug 1359052 ***

Note You need to log in before you can comment on or make changes to this bug.