Bug 967743 - Cannot reconnect to VPN
Cannot reconnect to VPN
Status: CLOSED DUPLICATE of bug 980467
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 04:33 EDT by David Woodhouse
Modified: 2013-09-20 16:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 16:27:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 707992 None None None Never

  None (edit)
Description David Woodhouse 2013-05-28 04:33:56 EDT
When my VPN session times out and the server disconnects me, I can no longer reconect. The VPN is displayed in the list of networks, with 'connection failed' where the switch should be to allow me to connect.

In order to connect to the VPN again, I need to restart gnome-shell.

May 26 10:03:24 i7 openconnect[9492]: Received server disconnect: b0 'Max time exceeded'
May 26 10:03:24 i7 openconnect[9492]: Send BYE packet: Server request
May 26 10:03:25 i7 NetworkManager[1608]: <info> Policy set 'Auto eth0' (eth0) as default for IPv4 routing and DNS.
May 26 10:03:25 i7 dbus-daemon[1531]: dbus[1531]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
May 26 10:03:25 i7 dbus[1531]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
May 26 10:03:25 i7 NetworkManager[1608]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
May 26 10:03:25 i7 NetworkManager[1608]: <warn> (17) failed to find interface name for index
May 26 10:03:25 i7 NetworkManager[1608]: nm_system_iface_flush_routes: assertion `iface != NULL' failed
May 26 10:03:25 i7 NetworkManager[1608]: <warn> (17) failed to find interface name for index
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: JS ERROR: !!!   Exception was: TypeError: obj.active is undefined
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: JS ERROR: !!!     message = '"obj.active is undefined"'
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/status/network.js"'
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: JS ERROR: !!!     lineNumber = '1564'
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: JS ERROR: !!!     stack = '"([object GObject_Object])@/usr/share/gnome-shell/js/ui/status/network.js:1564
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: wrapper([object GObject_Object])@/usr/share/gjs-1.0/lang.js:213
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: ()@/usr/share/gnome-shell/js/ui/status/network.js:2031
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: wrapper()@/usr/share/gjs-1.0/lang.js:213
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: ()@/usr/share/gnome-shell/js/ui/status/network.js:2292
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: wrapper()@/usr/share/gjs-1.0/lang.js:213
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: ([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gnome-shell/js/ui/status/network.js:2128
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: JS ERROR: !!!     lineNumber = '1564'
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: JS ERROR: !!!     stack = '"([object GObject_Object])@/usr/share/gnome-shell/js/ui/status/network.js:1564
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: wrapper([object GObject_Object])@/usr/share/gjs-1.0/lang.js:213
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: ()@/usr/share/gnome-shell/js/ui/status/network.js:2031
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: wrapper()@/usr/share/gjs-1.0/lang.js:213
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: ([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gnome-shell/js/ui/status/network.js:2292
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: wrapper([object GObject_Object],[object GObject_ParamSpec])@/usr/share/gjs-1.0/lang.js:213
May 26 10:03:25 i7 /etc/gdm/Xsession[2647]: "'
May 26 10:03:26 i7 dbus-daemon[1531]: dbus[1531]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
May 26 10:03:26 i7 dbus[1531]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
May 26 10:03:31 i7 NetworkManager[1608]: <info> VPN service 'openconnect' disappeared
Comment 1 Joe Wrigley 2013-07-26 06:25:44 EDT
I have had this problem, too.

I worked around it by calling the connection via nmcli:

$ nmcli connection
NAME                      UUID                                   TYPE              TIMESTAMP-REAL                    
<NAME>                    b6c3178c-42eb-4b16-89e1-50e5e35a6e0f   vpn               Fri 26 Jul 2013 11:21:14 BST     

$ nmcli /usr/bin/nmcli connection up uuid b6c3178c-42eb-4b16-89e1-50e5e35a6e0f
Comment 2 Dan Williams 2013-09-20 16:27:28 EDT
Should actually be caused by the shell's checkConnection() handling, thus duping to that bug.

*** This bug has been marked as a duplicate of bug 980467 ***

Note You need to log in before you can comment on or make changes to this bug.