Bug 967750 - Install issue via CD-ROM
Install issue via CD-ROM
Status: CLOSED DUPLICATE of bug 1002431
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joey Boggs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 04:53 EDT by Wenyi Gao
Modified: 2013-11-28 08:53 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 08:53:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshoto of install error (18.64 KB, image/png)
2013-05-28 04:53 EDT, Wenyi Gao
no flags Details

  None (edit)
Description Wenyi Gao 2013-05-28 04:53:47 EDT
Created attachment 753800 [details]
screenshoto of install error

Description of problem:

I built a ovirt-node iso using the latest upstream code, but I ran into some problems on installing it to host via CD-ROM

dracut-initqueue[698]: Warning: Could not boot.
dracut-initqueue[698]: Warning: /dev/disk/by-label/ovirt-node-image does not exist
dracut-initqueue[698]: Warning: /dev/mapper/live-rw does not exist


Then I change the boot parameter: root=live:LABEL=ovirt-node-image to
root=live:/dev/sr0,  the issue disappears, but got another issue:
please see the screenshot attached.
Comment 1 bohai 2013-07-24 22:59:43 EDT
I think it has been fixed.
Fix detail, please see 
http://gerrit.ovirt.org/#/c/16749/
Comment 2 Wenyi Gao 2013-07-25 00:13:15 EDT
I have tried the patct http://gerrit.ovirt.org/#/c/16749/, it still is the same issue.
Comment 3 mpaupe 2013-08-29 07:21:00 EDT
This is still a valid bug that can be reproduce with ovirt-node version 
ovirt-node-iso-3.0.1-1.0.1.vdsm.fc19.iso. 

The hardware is a IBM xserver 3650 M3 and HD completely empty. The install process
run in legacy mode.

I'm available to make some test.

Thanks
Comment 4 bohai 2013-08-29 23:33:13 EDT
Whether the attachement's problem occured before the install TUI is showed?

Can you add the debug option like the below , then make the iso ,reproduce the problem and get the below logs and the screenshot?

In file scripts/ovirt-init-functions.sh.in function start_ovirt_firstboot,
add the --debug option for the call of "/usr/bin/ovirt-node-installer ".

The logs need to get:
/var/log/ovirt.log
/var/log/ovirt-node.debug.log
/var/log/ovirt-node.log
Comment 5 Fabian Deutsch 2013-11-28 08:53:38 EST

*** This bug has been marked as a duplicate of bug 1002431 ***

Note You need to log in before you can comment on or make changes to this bug.