Bug 967755 - [register] unable to combine --servicelevel with --activationkey option
[register] unable to combine --servicelevel with --activationkey option
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-05-28 05:12 EDT by Garik Khachikyan
Modified: 2015-01-07 06:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 10:52:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2013-05-28 05:12:35 EDT
Description of problem:
Right now the recent available option of RHSM seems does not allow to combine service level with activation keys during registration.
It is useful stuff to have different activation keys (with different usage limits) and with different RHEL subscriptions attached to them (recent implementation of Katello allows it) with different support levels there.
So one may want to expose it wishing to perform something like:
===
subscription-manager register --activationkey akTesting --release 6.4 --force --name awesomeSystem --org awesomeOrg --servicelevel Premium --auto-attach
=== 

it just gets fails with:
===
WARNING

This system has already been registered with Red Hat using RHN Classic.

The tool you are using is attempting to re-register using Red Hat Subscription Management technology. Red Hat recommends that customers only register once.

To learn how to unregister from either service please consult this Knowledge Base Article: https://access.redhat.com/kb/docs/DOC-45563
Error: Activation keys cannot be used with --auto-attach.
===

Version-Release number of selected component (if applicable):
subscription-manager-1.1.23.1-1.el6_4.x86_64
python-rhsm-1.8.0-1.pulp.el6sat.x86_64


How reproducible:
always

Steps to Reproduce:
1.Setup a Katello
2.manifest import + enable repo sets of RHEL6Server
3.promote to Testing env
4.prepare ak for Testing, set limit to 3, add the RHEL subscription from that manifest.
5.configure rhsm to connect to the Katello
6.perform the command above

Actual results:
failure

Expected results:
available to set servicelevel on registration using AKs

Additional info:
Comment 3 William Poteat 2013-06-03 10:52:36 EDT
This must be run a separate commonads:

subscription-manager register --activationkey akTesting --release 6.4 --force --name awesomeSystem --org awesomeOrg


subscription-manager register --servicelevel Premium --auto-attach


These commands are mutually exclusive by design.
Comment 4 Garik Khachikyan 2013-06-03 10:59:13 EDT
I have nothing to argue if it "by-design" :) ty

Note You need to log in before you can comment on or make changes to this bug.