Bug 967780 - Bad perfomance in virt-install (network boot)
Bad perfomance in virt-install (network boot)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19-accepted/F19FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-05-28 06:33 EDT by Igor Gnatenko
Modified: 2013-06-12 15:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 15:59:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ps sort cpu load (2.70 KB, image/png)
2013-05-28 06:33 EDT, Igor Gnatenko
no flags Details

  None (edit)
Description Igor Gnatenko 2013-05-28 06:33:30 EDT
Created attachment 753820 [details]
ps sort cpu load

Description of problem:
Bad perfomance in virt-install (network boot)

Version-Release number of selected component (if applicable):
libvirt-1.0.5.1-1.fc19.x86_64
virt-manager-0.10.0-0.4.gitb68faac8.fc19.noarch
qemu-kvm-1.4.2-2.fc19.x86_64
virt-install-0.10.0-0.4.gitb68faac8.fc19.noarch
kernel-3.9.4-300.fc19.x86_64


How reproducible:
always

Steps to Reproduce:
1. virt-install --name fedoratestday --ram 1024 --disk path=/home/brain/fedoratestday.img,size=10 --location http://download.fedoraproject.org/pub/fedora/linux/development/19/x86_64/os/ or in virt-manager
2. Boot
3. Enter language
4. Calculate dependence 

Actual results:
Some letters aren't shown and bad performance (100% load cpu) 

Expected results:
Good performance

Additional info:
beta dvd|netinst works correctly
Comment 1 Fedora Blocker Bugs Application 2013-05-29 12:23:01 EDT
Proposed as a Freeze Exception for 19-final by Fedora user ignatenkobrain using the blocker tracking app because:

 Virtualization load from network imho shall work
Comment 2 Adam Williamson 2013-05-29 15:41:21 EDT
I can't reproduce this exactly. CPU load does seem to be generally higher in the kernel pair boot case where anaconda itself is retrieved from the remote repo, but I don't ever see it 'stick' at 100%.

if I do a kernel pair boot and pass 'inst.repo=http://dl.fedoraproject.org/pub/fedora/linux/development/19/x86_64/os/' then I see 100% CPU use for a short time during installer init, then it drops, then spikes to 100% for a while longer while 'calculating dependencies', then drops to almost 0% as long as I just sit on hub. when I start an install it again spikes to 100% a couple of times while partitioning, then when it settles into package installation, it tends to bounce between 20-30% and 100%. But at no point does it just 'stick' at 100% usage, and the times when it's at 100% seem to be reasonably related to actual operations happening at that point in time.
Comment 3 Cole Robinson 2013-06-12 15:59:18 EDT
Given lack of reproducer in Comment #2 and no follow up, closing. If someone can still reproduce, please reopen.

Note You need to log in before you can comment on or make changes to this bug.