Bug 967795 - openstack-nova: Add [keystone_authtoken] params from /usr/share/nova/nova-dist.conf to nova.conf
openstack-nova: Add [keystone_authtoken] params from /usr/share/nova/nova-dis...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: snapshot2
: 3.0
Assigned To: Pádraig Brady
Omri Hochman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 07:05 EDT by Omri Hochman
Modified: 2016-01-04 09:43 EST (History)
7 users (show)

See Also:
Fixed In Version: openstack-nova-2013.1.1-3.el6ost
Doc Type: Bug Fix
Doc Text:
The keystone_authtoken configuration parameters were previously placed in the distribution specific compute service configuration file. As a result scripts to update these defaults in the standard user editable configuration file failed to correctly update the configuration. Additionally the defaults, descriptions, and correct location were not made apparent to end users who manually edited the standard configuration file. The template for the user standard configuration file has been updated to include the keystone_authtoken configuration keys.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 14:55:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omri Hochman 2013-05-28 07:05:59 EDT
[keystone_authtoken] section from /usr/share/nova/nova-dist.conf should be reflected in nova.conf.

According the request from :https://bugzilla.redhat.com/show_bug.cgi?id=958497#c7

[keystone_authtoken]
admin_tenant_name = %SERVICE_TENANT_NAME%
admin_user = %SERVICE_USER%
admin_password = %SERVICE_PASSWORD%
auth_host = 127.0.0.1
auth_port = 35357
auth_protocol = http
Comment 3 Omri Hochman 2013-06-03 09:14:33 EDT
Verified openstack-nova-2013.1.1-3.

The following exist under /etc/nova/nova.conf : 

[keystone_authtoken]

# the name of the admin tenant (string value)
#admin_tenant_name=%SERVICE_TENANT_NAME%

# the keystone admin username (string value)
#admin_user=%SERVICE_USER%

# the keystone admin password (string value)
#admin_password=%SERVICE_PASSWORD%

# the keystone host (string value)
#auth_host=127.0.0.1

# the keystone port (integer value)
#auth_port=35357

# protocol to be used for auth requests http/https (string value)
#auth_protocol=http
Comment 4 errata-xmlrpc 2013-06-11 14:55:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0936.html

Note You need to log in before you can comment on or make changes to this bug.