Bug 967799 - Beaker shows a 500 error when modifying group name to a name which already exists
Beaker shows a 500 error when modifying group name to a name which already ex...
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
develop
Unspecified Unspecified
medium Severity medium (vote)
: 0.13
: ---
Assigned To: Amit Saha
Nick Coghlan
UX
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 07:10 EDT by xjia
Modified: 2015-07-26 18:15 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 02:27:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xjia 2013-05-28 07:10:27 EDT
Description of problem:
Create a group named group1, and create another group named group2. Then modify group2's name to group1, it will show 500 error.

Version-Release number of selected component (if applicable):
beaker-server-redhat-0.1.14-1.el6eng.noarch
beaker-server-0.12.1-1.git.133.6c74a92.el6.noarch

How reproducible:
Always.

Steps to Reproduce:
1.Create a group named group1.
2.Creage a group named group2
3.Mofidy group2, change its name to "group1"
4.Save it

Actual results:
500 Internal error

Expected results:
Show the name has already existed.

Additional info:
Comment 1 Nick Coghlan 2013-05-28 21:31:43 EDT
Actually bringing this one into scope for 0.13, since people *will* do this in production and it should give them a nice error.
Comment 2 Amit Saha 2013-06-02 07:37:34 EDT
On Gerrit: http://gerrit.beaker-project.org/#/c/2007/2
Comment 4 Nick Coghlan 2013-06-06 03:53:16 EDT
Confirmed this works as expected on the integration instance:

1. Attempted to rename an existing group to the name of another existing group
2. Received a notification that a group with that name already existed
3. Existing group was left unchanged
Comment 6 Amit Saha 2013-06-25 02:27:08 EDT
Beaker 0.13.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.