Bug 967850 - rhn-satellite-exporter: AttributeError caught in dump_channel_families.
rhn-satellite-exporter: AttributeError caught in dump_channel_families.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Martin Minar
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-05-28 08:24 EDT by Jan Hutař
Modified: 2016-07-03 20:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.9.46-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:54:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-05-28 08:24:29 EDT
Description of problem:
Export of an channel fails.


Version-Release number of selected component (if applicable):
spacewalk-backend-tools-1.9.46-14.el5sat


How reproducible:
always


Steps to Reproduce:
1. # rhn-satellite-exporter -c mychannel -d /tmp/xxx


Actual results:
# rhn-satellite-exporter -c mychannel-ia64-11573 -d /tmp/xxx
08:18:34 Gathering channel info...
Appending channels []
08:18:34 Gathering binary RPM info...
08:18:34 Gathering package info...
08:18:34 Gathering errata info...
08:18:34 Gathering kickstart data...
08:18:34 Gathering kickstart files info...


08:18:34 Exporting channel families...
           ____________________
Exporting: 08:18:34 
AttributeError caught in dump_channel_families.


Expected results:
Channel should be exported.
Comment 3 Michael Mráka 2013-05-29 04:54:51 EDT
Fixed in
commit 881d1cc902a2128ee98fdba13bad1cd3b842724b
    967850 - don't change global configuration component for reading product name
Comment 4 Michael Mráka 2013-05-29 07:42:41 EDT
Backported to SATELLITE-5.6 as
commit 92d158f104321cfe0f92898157589f0384fce085
    967850 - don't change global configuration component for reading product name
Comment 7 Clifford Perry 2013-10-01 17:54:10 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.