Bug 967855 - engine: unlock_entity is not locating locked snapshots
engine: unlock_entity is not locating locked snapshots
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity high
: ---
: 3.1.5
Assigned To: Eli Mesika
Pavel Stehlik
infra
: ZStream
: 958341 (view as bug list)
Depends On: 958370
Blocks: 902971 948448
  Show dependency treegraph
 
Reported: 2013-05-28 08:30 EDT by Idith Tal-Kohen
Modified: 2016-02-10 14:32 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, unlock_entity failed to find locked snapshots and unlock them even after the associated virtual machine and virtual disk were unlocked successfully. Now, locked snapshots are appropriately unlocked along with their associated virtual machines and virtual disks.
Story Points: ---
Clone Of: 958370
Environment:
Last Closed: 2013-06-18 05:35:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 14494 None None None Never
oVirt gerrit 14530 None None None Never

  None (edit)
Comment 1 Barak 2013-06-03 09:00:34 EDT
*** Bug 958341 has been marked as a duplicate of this bug. ***
Comment 3 Aharon Canan 2013-06-10 11:41:24 EDT

verified using 3.1.5 (si29)

verification steps:
1. lock snapshots
   a. enter the engine DB
   b. run - "UPDATE snapshots SET status='LOCKED' where status='OK';"
2. check that snapshots are locked
   ("select snapshot_id,description,status from snapshots ;")
3. run - "./unlock_entity.sh  -t snapshot -i <snapshot_id> -u engine"
Comment 6 errata-xmlrpc 2013-06-18 05:35:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0950.html

Note You need to log in before you can comment on or make changes to this bug.