Bug 967861 - When RHEL VMs are powered off/on time is off by as much as 3 hrs when system comes back up
When RHEL VMs are powered off/on time is off by as much as 3 hrs when system ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
All Linux
high Severity high
: ---
: 3.2.1
Assigned To: Frantisek Kobzik
Tareq Alayan
virt
: ZStream
Depends On: 956741
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 08:43 EDT by Idith Tal-Kohen
Modified: 2014-05-29 04:01 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Previously, the time zone for a Red Hat Enterprise Linux virtual machine could be set in the Initial Run tab of the New or Edit Virtual Machine window. Now, the default time zone which is Etc/GMT is used, and it cannot be changed via the administration portal. After an upgrade, the time zones of all Red Hat Enterprise Linux virtual machines are reset to Etc/GMT. If you are using a Linux virtual machine with a non-default time zone, adjust its hardware clock to your desired time zone.
Story Points: ---
Clone Of: 956741
Environment:
Last Closed: 2013-07-16 09:38:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15802 None None None Never

  None (edit)
Comment 1 Michal Skrivanek 2013-06-07 02:46:45 EDT
pending consensus where the bug 964177 is going to be addressed
Comment 2 Andrew Cathrow 2013-06-10 08:47:54 EDT
Proposing the following.

For Linux VMs only.
- Disable timezone in VM properties - set to GMT with no edit option (in GUI or API)
- Discard TZ offset
- Always start VM with host (UTC) time.

For Windows we need another solution for 3.3
Comment 3 Michal Skrivanek 2013-06-11 09:59:11 EDT
we need a rel note for people who explicitly unchecked "HW clock in UTC" during Linux installations
Comment 4 Michal Skrivanek 2013-06-13 08:49:39 EDT
For Windows I'd see something like:
change the place in GUI where TZ is
change the meaning to true TZ setting which can be changed anytime (when VM down)
add TZ reporting to guest agent from guest OS
display current TZ in VM subtab
Supposing mapping it back from guest to RHEV-M setting may be tricky, perhaps alert when the time offset differs?

should go into a follow up bug
Comment 9 Tareq Alayan 2013-06-26 11:00:45 EDT
verified. 
Couldn't reproduce
Comment 11 errata-xmlrpc 2013-07-16 09:38:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1048.html

Note You need to log in before you can comment on or make changes to this bug.