Bug 967877 - CorrelationPersistenceTest fails on oracle11gR2 and mssql2008R2
CorrelationPersistenceTest fails on oracle11gR2 and mssql2008R2
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: 6.0.0
Assigned To: Maciej Swiderski
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 09:10 EDT by Jiri Svitak
Modified: 2015-06-01 21:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mssql and oracle stacktraces from jenkins job (14.88 KB, text/plain)
2013-05-28 09:10 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-05-28 09:10:42 EDT
Created attachment 753915 [details]
mssql and oracle stacktraces from jenkins job

org.jbpm.persistence.correlation.CorrelationPersistenceTest fails on oracle11gR2 and mssql2008R2. 

MS SQL 2008 R2:
org.hibernate.exception.SQLGrammarException: Column 'CorrelationKeyInfo.processInstanceId' is invalid in the select list because it is not contained in either an aggregate function or the GROUP BY clause.

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/Drools%20jBPM/view/All/job/jbpm-persistence-db-matrix/DATABASE=mssql2008R2,MODULES=jbpm-persistence-jpa,jdk=java16_default,label=RHEL_any/lastCompletedBuild/testReport/org.jbpm.persistence.correlation/CorrelationPersistenceTest/testCreateCorrelation/

Oracle 11g R2:
org.hibernate.exception.SQLGrammarException: ORA-00979: not a GROUP BY expression

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/Drools%20jBPM/view/All/job/jbpm-persistence-db-matrix/DATABASE=oracle11gR2,MODULES=jbpm-persistence-jpa,jdk=java16_default,label=RHEL_any/lastCompletedBuild/testReport/org.jbpm.persistence.correlation/CorrelationPersistenceTest/testCreateCorrelation/

All three CorrelationPersistenceTest fails on these databases. On MySQL and PostgreSQL these tests are passing without problems. Whole stacktraces are attached to this bugzilla. The build was run against jbpm master on 2013-05-25.

To reproduce either configure jbpm test suite to use Oracle/MS SQL databases or use https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/Drools%20jBPM/view/All/job/droolsjbpm-persistence-db-single/
Comment 5 Lukáš Petrovický 2014-02-07 11:14:56 EST
This BZ has been part of the 6.0.0 stream.

Note You need to log in before you can comment on or make changes to this bug.