Bug 967894 - Evolution 'hangs' retrieving a message
Evolution 'hangs' retrieving a message
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 09:59 EDT by Eric Paris
Modified: 2013-05-31 12:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: evolution-data-server-3.8.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 12:15:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2013-05-28 09:59:18 EDT
evolution-3.8.2-1+git20130523.fc19.x86_64

sometimes, and I don't know why, evolution will 'hang' when I click on a new message.  Inside the preview pane it says something like: "Retrieving message '767406'"  In the bottom left evolution first says it is retrieving the new message, but then that goes away.  The message never appears in the preview pane.

I will attach a copy of CAMEL_DEBUG=imapx evolution > ~/evolution.log 2>&1 

The message in question is 767406
Comment 2 Eric Paris 2013-05-28 10:20:44 EDT
It is possible this is a complete red herring, but I may have deleted the message in question from my cell phone, using touchdown.  Evolution may have been running and connected to the server when this happened...  (it also might not and it's possible I didn't even delete the message in question that way, but it might be relevant...)

I remember the last time I gave up on evolution it was because it got angry when I deleted messages from my cell phone and the only way I could recover was to delete .cache/evolution and start over.
Comment 3 Milan Crha 2013-05-31 12:15:08 EDT
Thanks for a bug report. I see the reason in the log, it's because the server doesn't like QResync, and returns:
> BAD parse error: invalid message sequence number
Matthew only recently addressed this upstream [1]. Current workaround is to disable Quick Sync in account preferences (it might require evolution's restart).

[1] https://git.gnome.org/browse/evolution-data-server/commit/?h=gnome-3-8&id=fe53fde76b9521638b57e28250de8af16e58d206

Note You need to log in before you can comment on or make changes to this bug.