Bug 967914 - ejecting cdrom in virt-manager gives 'tray is locked' error, but succeeds on next try
ejecting cdrom in virt-manager gives 'tray is locked' error, but succeeds on ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
: 951114 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 10:41 EDT by Cole Robinson
Modified: 2013-06-29 14:45 EDT (History)
10 users (show)

See Also:
Fixed In Version: libvirt-1.0.5.2-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 14:45:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2013-05-28 10:41:05 EDT
Trying to eject a cdrom from an active F19 guest always gives:

libvirtError: internal error unable to execute QEMU command 'eject': Device 'drive-ide0-1-0' is locked

But on the next try it succeeds.

Should be fixed with these two commits:

commit 543af79a14f06cd16844c28887210bbb93a455fa
Author: Michal Privoznik <mprivozn@redhat.com>
Date:   Mon May 20 19:26:14 2013 +0200

    qemuDomainChangeEjectableMedia: Unlock domain while waiting for event


and: https://www.redhat.com/archives/libvir-list/2013-May/msg01919.html
Comment 1 Cole Robinson 2013-06-12 15:51:47 EDT
*** Bug 951114 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2013-06-12 18:08:27 EDT
libvirt-1.0.5.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libvirt-1.0.5.2-1.fc19
Comment 3 Fedora Update System 2013-06-13 14:05:52 EDT
Package libvirt-1.0.5.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-1.0.5.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10769/libvirt-1.0.5.2-1.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-06-29 14:45:59 EDT
libvirt-1.0.5.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.