Bug 967919 - Pulp Consumer Groups - action responses appear incorrect
Pulp Consumer Groups - action responses appear incorrect
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Jeff Ortel
Og Maciel
: Triaged
Depends On:
Blocks: 955706
  Show dependency treegraph
 
Reported: 2013-05-28 10:51 EDT by Brad Buckingham
Modified: 2014-01-27 09:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:18:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2013-05-28 10:51:11 EDT
Description of problem:

When a pulp user sends a request to perform an action (e.g. pkg install) on a consumer group, the response and resulting action appear incorrect.

In case it is related, the following BZ was created in the past for consumer group actions: bug 878234.

As part of this BZ, need to ensure that all of following actions are supported:
- package install/update/remove
- package group install/update/remove
- errata install

If possible, documentation on the API and responses would also be helpful.

Version-Release number of selected component (if applicable):
pulp-server-2.1.1-0.10.beta.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. create 2 consumers (A & B)
2. create a consumer group (X)
3. associate the 2 consumers (A & B) to the group (X)
4. attempt a package install action (e.g. xterm) on consumer group X

Actual results:

The initial response to action looks similar to the following:
{"task_group_id"=>nil, "exception"=>nil, "traceback"=>nil, "_href"=>"/pulp/api/v2/tasks/1c56f5a0-9424-4832-8075-45008ad7c841/", "task_id"=>"1c56f5a0-9424-4832-8075-45008ad7c841", "call_request_tags"=>["pulp:consumer:b5bc4bd5-e5c0-4ffe-99ac-f9a4d854415d", "pulp:action:unit_install"], "reasons"=>[], "start_time"=>nil, "tags"=>["pulp:consumer:b5bc4bd5-e5c0-4ffe-99ac-f9a4d854415d", "pulp:action:unit_install"], "state"=>"waiting", "finish_time"=>nil, "dependency_failures"=>{}, "schedule_id"=>nil, "progress"=>{}, "call_request_group_id"=>nil, "call_request_id"=>"1c56f5a0-9424-4832-8075-45008ad7c841", "principal_login"=>"admin", "response"=>"accepted", "result"=>nil}

The above only includes 1 (i.e. A) of the 2 (i.e. A & B) consumers.
In addition, the package is only installed on consumer A.

Expected results:

Ideally, would expect the result to include information such as:
- the 'job' that was created
- the list 'tasks' that were created (e.g. 1 for each consumer)

Packages installed on all consumers in the group (A & B)


Additional info:
Comment 1 Mike McCune 2013-06-19 10:58:00 EDT
the pulp bugfix is already in SNAP5, moving ON_QA
Comment 3 Og Maciel 2013-06-19 11:09:09 EDT
Verified:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10011-1.noarch
* foreman-compute-1.1.10011-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10011-1.noarch
* foreman-postgresql-1.1.10011-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-14.el6sat.noarch
* katello-all-1.4.2-14.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-14.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-14.el6sat.noarch
* katello-glue-candlepin-1.4.2-14.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-14.el6sat.noarch
* katello-glue-pulp-1.4.2-14.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.2-0.3.beta.el6sat.noarch
* pulp-selinux-2.1.2-0.3.beta.el6sat.noarch
* pulp-server-2.1.2-0.3.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.18-1.el6sat.noarch
* signo-katello-0.0.18-1.el6sat.noarch
Comment 4 Mike McCune 2013-07-18 17:18:11 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.